Go Back   PowerStrokeArmy > Power Strokes > 7.3 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 04-08-2013, 05:50 PM
oldschool oldschool is offline
Sergeant
Member's Gallery
 
Join Date: Jun 2011
Location: casper Wy
Posts: 269
Default cracked front cover

I've got a 1996 leaking water. This is the second one and was wondering if anyone else had this problem or I'm just lucky. It's cracked right behind the top oil cooler mounting threaded hole.




the crack makes a "L" shape, runs along the water port then goes up to the thread.
Any Ideas? Just resealed the oil cooler, as it had been leaking oil. This winter had a water leak when it was cold, but dried up after it ran a while. Thought it might be the water pump, but after I cleaned the area, maybe it was this leaking? Sucks, cause I gotta pull the engine again!

Last edited by oldschool; 04-08-2013 at 05:52 PM.
  #2  
Old 04-08-2013, 06:06 PM
CSIPSD's Avatar
CSIPSD CSIPSD is offline
General
Member's Gallery
 
Join Date: May 2011
Location: Bend, OR
Posts: 5,288
Default

Is something pressing down on the oil cooler?
__________________
01 F-250 SC PSD,320k,16 Isspro Gauges, AFE-2,CCV Mod,IAH ******,map reg,Modded H2e, 6.0 IC, 230/100 from P.I.S, Studs, 910 springs, Forged rods, Water injection,Hydra chip-No Limit/******** tuning, Swamps HVHF IDM, MBRP 4" dual's, Aero, 6" tip's, 4" Revtek lift, 37/12.5/16.5 MT's
Joe

Honey Badger HPOP
Powerstroke Injectors
  #3  
Old 04-08-2013, 06:15 PM
littleredstroker's Avatar
littleredstroker littleredstroker is offline
Colonel
Member's Gallery
 
Join Date: Jun 2011
Location: where the antelope play
Posts: 3,720
Default

Subbed

sent while needing more cowbell
__________________
458 hp 845 ftlb 2003 f250
******** tunes 250/100%
studs, springs, fuel bow ******, dual fuel pumps
turbonetics drop in, forged rods

Quote:
Originally Posted by Dzchey21 View Post
you have entirely too much time to whack off.
  #4  
Old 04-08-2013, 06:28 PM
oldschool oldschool is offline
Sergeant
Member's Gallery
 
Join Date: Jun 2011
Location: casper Wy
Posts: 269
Default

Quote:
Originally Posted by CSIPSD View Post
Is something pressing down on the oil cooler?
No, everything is free, and where it should be, not external pressure
  #5  
Old 04-08-2013, 06:40 PM
CSIPSD's Avatar
CSIPSD CSIPSD is offline
General
Member's Gallery
 
Join Date: May 2011
Location: Bend, OR
Posts: 5,288
Default

I've never seen one crack like that... Not really sure what could cause it other then vibration.
__________________
01 F-250 SC PSD,320k,16 Isspro Gauges, AFE-2,CCV Mod,IAH ******,map reg,Modded H2e, 6.0 IC, 230/100 from P.I.S, Studs, 910 springs, Forged rods, Water injection,Hydra chip-No Limit/******** tuning, Swamps HVHF IDM, MBRP 4" dual's, Aero, 6" tip's, 4" Revtek lift, 37/12.5/16.5 MT's
Joe

Honey Badger HPOP
Powerstroke Injectors
  #6  
Old 04-08-2013, 07:05 PM
oldschool oldschool is offline
Sergeant
Member's Gallery
 
Join Date: Jun 2011
Location: casper Wy
Posts: 269
Default

Quote:
Originally Posted by CSIPSD View Post
I've never seen one crack like that... Not really sure what could cause it other then vibration.
Like I said, this is the second one i've had. Both in the same truck with different engines. Thought maybe a bad design, that's why I'd thought I'd ask if anyone else had problems. If not, I don't know. If it was bad motor mounts, would see it hitting somewhere, and it would torque the other way, oil cooler is on the left side. Got me stumpped. Funny it started to leak after the cooler re-seal? didn't impact bolts, all were hand tightened, didn't feel anything strange going together?
  #7  
Old 04-13-2013, 10:40 AM
Old OutLaw's Avatar
Old OutLaw Old OutLaw is offline
Sergeant
Member's Gallery
 
Join Date: Mar 2012
Location: Suthren OryGun
Posts: 206
Default

well, if it cracked after you did the cooler, I'd think that you probably Hydraulic'd it when you tightened
the bolts.....
wouldn't take much oil-water-crud in there to crack that little aluminum housing ....

sucks....
__________________
'97 Centurion. F350 4x4 CCLB
Full Force 180cc Stage I's, D66, Stealth SRP-1.1, ARP, Banks IC,
DIY E-Fuel, EBPV Del & Gut'd Ped., BD Brake., SD IDM, HPX, BstFoolr, DIY 4" DP - 4" exh
6.0 Fan, 180 T-Stat, DIY Don.105006 AF, CCV Mod, BTS, 3/8" Cooling lines, Tru-Cool Max, PML, Bumper Mod, Gauges, Fluidampr, Mellings LPOP..... Tuned by "The WildMan".....

  #8  
Old 04-13-2013, 01:25 PM
oldschool oldschool is offline
Sergeant
Member's Gallery
 
Join Date: Jun 2011
Location: casper Wy
Posts: 269
Default

Quote:
Originally Posted by Old OutLaw View Post
well, if it cracked after you did the cooler, I'd think that you probably Hydraulic'd it when you tightened
the bolts.....
wouldn't take much oil-water-crud in there to crack that little aluminum housing ....

sucks....
dont think so, the top bolt hole goes all the way through. and everything was hand tightened. the new cover in that area is a lot heavier and the bolt hole is blind. I i think is was seeping before the cooler re-seal. there was some accumulation of coolant when it was cold, thought that it might be the cooler, but after looking how the cooler is sealed, coolant can't leak externaly from the seals. the water pump weep hole showed no sign of leaking.

Last edited by oldschool; 04-13-2013 at 01:29 PM.
  #9  
Old 04-13-2013, 10:42 PM
Old OutLaw's Avatar
Old OutLaw Old OutLaw is offline
Sergeant
Member's Gallery
 
Join Date: Mar 2012
Location: Suthren OryGun
Posts: 206
Default

OK, cool, I couldn't see the hole going clear thru....my bad.
__________________
'97 Centurion. F350 4x4 CCLB
Full Force 180cc Stage I's, D66, Stealth SRP-1.1, ARP, Banks IC,
DIY E-Fuel, EBPV Del & Gut'd Ped., BD Brake., SD IDM, HPX, BstFoolr, DIY 4" DP - 4" exh
6.0 Fan, 180 T-Stat, DIY Don.105006 AF, CCV Mod, BTS, 3/8" Cooling lines, Tru-Cool Max, PML, Bumper Mod, Gauges, Fluidampr, Mellings LPOP..... Tuned by "The WildMan".....

  #10  
Old 04-14-2013, 05:25 AM
bad12jr's Avatar
bad12jr bad12jr is offline
Major
Member's Gallery
 
Join Date: May 2011
Posts: 1,244
Default

I had mine crack. I think it was a bad run of castings personally. I swapped to a 2001 cover,pan and pickup. It has a brace cast into it right there. From what I can tell it was late 95 early 96 models from the others I've seen of peoples cracking. I'm going to try and weld my 96 up whenever I get a tig for aluminum.
And when I had the leak I resealed the oil cooler first before finding the crack. Should have just pulled the motor first but oh well. To close to get a welder in without pulling as well.

Sent from my x2 chillin in the middle of no where
__________________
1996 F250 211000 on the clock
5spd XL
6637, SD Electric Fuel, 3'' DP to 5'' Tailpipe, Pyro, Boost and Oil Psi,
140cc AD SD injectors, T500 HPOP and ******** Tunes. Traction Bars.
300hp 500ft/lbs torque

2002 F250 sport sclb 144000 miles
BTS, 160cc stage 1's, studs, billet rods, banks ic, adrenaline Hpop, RR,
Van Turbo w/ ATS housing, AFE stage 2, 5" Turbo back, ******** tunes
15.27 @ 85mph

Last edited by bad12jr; 04-14-2013 at 05:30 AM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:31 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd