Go Back   PowerStrokeArmy > Power Strokes > 6.7 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 11-17-2020, 02:46 PM
eclipsemf eclipsemf is offline
Private
Member's Gallery
 
Join Date: Mar 2017
Posts: 23
Default 6.7l EGT Sensor Codes

I just got done replacing the CP4 and fuel system on this truck and finally got it running. Runs great besides the reduce power flashing on the truck. I pulled the codes and it is all 4 banks of the EGT sensors. I looked underneath and it has no sensors on the exhaust and the wires just hanging out there. It has a "custom" exhaust put on by the previous owner.

My question is whats the easiest way to go about getting that fixed or do I even need them? Is there a good tuner I can use to bypass them? This is a truck I am flipping so just need it to get back to the codes gone so I can move it

Thanks in advance!
  #2  
Old 11-17-2020, 04:13 PM
sootie's Avatar
sootie sootie is offline
General
Member's Gallery
 
Join Date: Oct 2012
Posts: 11,684
Default

you need to reinstall the factory exhaust or program the truck with a race tune.
  #3  
Old 11-18-2020, 08:01 AM
eclipsemf eclipsemf is offline
Private
Member's Gallery
 
Join Date: Mar 2017
Posts: 23
Default

Okay thank you for the response that what I figured. I see there are a ton of options out there for tuners. Any you recommend in this case cheapest is better for me so I can get the truck gone and be done w it!

Looks like a SCT x4 is what I will be going with

Last edited by eclipsemf; 11-18-2020 at 08:31 AM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:03 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd