Go Back   PowerStrokeArmy > Power Strokes > 6.0 Tech

Reply
 
Thread Tools Display Modes
  #51  
Old 08-16-2018, 11:26 AM
CTC DEEZUL's Avatar
CTC DEEZUL CTC DEEZUL is offline
General
Member's Gallery
 
Join Date: Jun 2011
Location: NWI
Posts: 5,095
Default

Clogged radiator sends super cool coolant out lower.
__________________
Teamsters Local 444- Rolling Coal United
  #52  
Old 08-17-2018, 10:04 AM
Jtreece's Avatar
Jtreece Jtreece is offline
Corporal
Member's Gallery
 
Join Date: Jun 2018
Location: Kansas
Posts: 85
Default

well then it can't be that then, could it be the radiator just isn't cooling the coolant? or the water pump is junk? (water pump is less than 2 months old)
__________________
04 F350 CCLW SRW, 35's, CM skirted flatbed, Diablo T1000, SCT3, Studded, *******, 4", Stage 2 Tranny, blue spring, wicked wheel, loves to eat Hondas.
  #53  
Old 08-17-2018, 10:04 AM
Jtreece's Avatar
Jtreece Jtreece is offline
Corporal
Member's Gallery
 
Join Date: Jun 2018
Location: Kansas
Posts: 85
Default

or I need to pull the rad and pressure wash it out?
__________________
04 F350 CCLW SRW, 35's, CM skirted flatbed, Diablo T1000, SCT3, Studded, *******, 4", Stage 2 Tranny, blue spring, wicked wheel, loves to eat Hondas.
  #54  
Old 08-17-2018, 10:18 AM
CTC DEEZUL's Avatar
CTC DEEZUL CTC DEEZUL is offline
General
Member's Gallery
 
Join Date: Jun 2011
Location: NWI
Posts: 5,095
Default

Wow.

Dude just take this to a good shop
__________________
Teamsters Local 444- Rolling Coal United
  #55  
Old 08-17-2018, 10:28 AM
Jtreece's Avatar
Jtreece Jtreece is offline
Corporal
Member's Gallery
 
Join Date: Jun 2018
Location: Kansas
Posts: 85
Default

that's the problem, I did take it to a reputable shop who work on 95% of the 6.0's around here. Trying not to kill the bank account and we can all relate to that who own a 6.0.

they replaced the ficm, oil/coolant temp sensors, oil/coolant bypass filters, turbo solenoid and pigtail, injectors, injector harness, glow plug harness, thermostat, fan clutch, oil cooler, filters, oil, starter, tranny solenoids, tranny pan/gasket, blue spring upgrade, updated diablo T1000 and SCT X3, all new gaskets etc.

I'm looking for someone who has experienced this and looking for advice, I will take your advice with a grain of saltiness. Maybe its an easy fix maybe its not.
__________________
04 F350 CCLW SRW, 35's, CM skirted flatbed, Diablo T1000, SCT3, Studded, *******, 4", Stage 2 Tranny, blue spring, wicked wheel, loves to eat Hondas.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:49 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd