Go Back   PowerStrokeArmy > Power Strokes > 6.0 Tech

Reply
 
Thread Tools Display Modes
  #11  
Old 03-11-2018, 10:58 AM
webb06's Avatar
webb06 webb06 is offline
Colonel
Member's Gallery
 
Join Date: Aug 2012
Location: Seneca, MO
Posts: 3,694
Default

Quote:
Originally Posted by HobbyStock62 View Post
Im just at a loss here, I put new o-rings and washer on the injector, checked the cup and hole (as good as you can with the head in the truck) didnt see any issues, replaced the injector hold down and bolt and its now a constant miss in 8, from the second I started it. Checked the FICM, and injector harness, all is good there. I dont want to say it, but I think I got to pull the head. I mean, I dont know what the next step other than that would be?


Do you have a way to check compression on 8 first? To rule out anything electrical


Sent from my iPhone using Tapatalk
  #12  
Old 03-11-2018, 02:38 PM
HobbyStock62's Avatar
HobbyStock62 HobbyStock62 is offline
Sergeant
Member's Gallery
 
Join Date: Dec 2012
Location: Mpls, MN
Posts: 444
Default

Yes, I can check compression. I'll try to make some time for that tomorrow.
__________________
I am a ginger.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:37 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd