Go Back   PowerStrokeArmy > Power Strokes > 94-97 Tech

Reply
 
Thread Tools Display Modes
  #11  
Old 11-09-2020, 07:09 PM
chaselee's Avatar
chaselee chaselee is offline
Sergeant
Member's Gallery
 
Join Date: May 2016
Posts: 285
Default

Yep! They are all LEDs. How did you know that your resistor had failed? Also I thought if a resistor failure happened it would just hyper flash as it you didn't have one?
__________________
1996 CCSB Auto, John Wood VB, Dual disc TC, 4.10 gears, Irate efuel, super duty intercooler, BW 364.5 sxe turbo, 4" turbo back, AFE CAI, Full force 205/80 sticks, 1023 Hydra tunes, 4" lift d60 swap, 37" Maxxis razr MT.
  #12  
Old 11-10-2020, 06:58 AM
79jasper's Avatar
79jasper 79jasper is offline
Colonel
Member's Gallery
 
Join Date: Feb 2012
Location: skiatook, Oklahoma
Posts: 2,594
Default

It still may not be giving enough load to make it flash at all.

Sent from my SM-G988U using Tapatalk
__________________
2003 F250 KR SCSB FX4
Depleted, studded, airdog (which isn't currently hooked up), fass regulated return, airaide, 4 inch straight pipe with mbrp muffler(so on to go), glowchit pyro, fuel, boost, and trans temp. (Of course don't work lol) Hercules terra track A/T2 315/70/17.
2013 Honda pilot Touring
http://badges.fuelly.com/images/sig-us/778639.png
http://badges.fuelly.com/images/sig-us/776628.png
  #13  
Old 11-10-2020, 10:17 AM
MossBack's Avatar
MossBack MossBack is offline
Lieutenant
Member's Gallery
 
Join Date: Aug 2011
Location: UTAH
Posts: 932
Default

^^79Jasper is right. ^^ I had lost my right turn signal just like you said. It may have been corroded. bought new resistors and all was fine.
__________________
my rig: 1997 F-250 7.3 180/80 FFD. T500, S468, Pushrods and springs, Efuel
  #14  
Old 11-10-2020, 10:33 AM
chaselee's Avatar
chaselee chaselee is offline
Sergeant
Member's Gallery
 
Join Date: May 2016
Posts: 285
Default

Quote:
Originally Posted by MossBack View Post
^^79Jasper is right. ^^ I had lost my right turn signal just like you said. It may have been corroded. bought new resistors and all was fine.
Ok I'll try that. Thanks fellas!
__________________
1996 CCSB Auto, John Wood VB, Dual disc TC, 4.10 gears, Irate efuel, super duty intercooler, BW 364.5 sxe turbo, 4" turbo back, AFE CAI, Full force 205/80 sticks, 1023 Hydra tunes, 4" lift d60 swap, 37" Maxxis razr MT.
  #15  
Old 11-16-2020, 04:20 PM
chaselee's Avatar
chaselee chaselee is offline
Sergeant
Member's Gallery
 
Join Date: May 2016
Posts: 285
Default

Well y'all some bad mofos!! Finally had a chance to switch out the resistor....and Magic!! I've got a right blinker again! Thanks again fellas!
__________________
1996 CCSB Auto, John Wood VB, Dual disc TC, 4.10 gears, Irate efuel, super duty intercooler, BW 364.5 sxe turbo, 4" turbo back, AFE CAI, Full force 205/80 sticks, 1023 Hydra tunes, 4" lift d60 swap, 37" Maxxis razr MT.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:46 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd