Go Back   PowerStrokeArmy > Power Strokes > 6.0 Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-03-2018, 06:25 AM
Jtreece Jtreece is offline
Private
Member's Gallery
 
Join Date: Jun 2018
Location: Kansas
Posts: 37
Default 04 6.0 Deltas GURU's

ok where are the 6.0 guru's?? need some advice.

2004 f350 CCLW SRW weighs 9230lbs on 35's CM skirted flatbed
Diablo monitor and SCT3 both on stock tune
ARP studded, ******D wicked wheel, stage 2 tranny 4" downpipe and exhaust (no kitty), new FICM
NEW aluminum radiator, 192 tstat, coolant sensor, fan clutch and bypass filter
New OEM oil cooler, oil temp sensor, all new seals, new bypass filter
8 new motor craft stock injectors, new ficm wiring harness, new solenoids in tranny
all new coolant, oil and tranny fluid. (same as what it was running before)

75 degrees AC on at 65mph ect 199 and eot 206
95 degrees AC on at 65mph ect 212(touched 217 yesterday) and eot 219-220
not pulling a trailer either
fan comes (seems like medium speed) on and kicks it back down ect to 208-209ish and eot 218ish

before all of this it use to run CONSTAT at ect 192 and eot 199-200

any and all advice or help is appreciated fellas because this pickup is about to get set on fire by the wife so for the love of god and ford please help.

is this normal???
__________________
04 F350 CCLW SRW, 35's, CM skirted flatbed, Diablo T1000, SCT3, Studded, *******, 4", Stage 2 Tranny, blue spring, wicked wheel, loves to eat Hondas.

Last edited by Jtreece; 07-03-2018 at 06:29 AM.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:03 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd