Go Back   PowerStrokeArmy > Power Strokes > 6.7 Aftermarket

Reply
 
Thread Tools Display Modes
  #21  
Old 07-11-2018, 07:26 AM
ToMang07's Avatar
ToMang07 ToMang07 is offline
General
Member's Gallery
 
Join Date: Jan 2012
Location: Mainah!
Posts: 5,732
Default

Fluid level good and all the air out of the lines?
__________________
~Tom~ 02 F350 CCSB 4x4 SRW 7.3L, DIY-6637, Hydra, 4" TB-409SS MBRP, GS 3 in 1, EGT/Boost/Tranny, T500, FRx, COMP 910s, Fisher 8' MM2, 5" AL 1-piece Drive Shaft, Tymar HPX, NON-EBV Pedestal, Turbo Master, Wicked Wheel, Hutch/Harpoon, RR-Plenums/clamps, 203* TS and Billet Housing, ELC, Fumoto, Leveled, Airlift Bags, 16x10" on 35s, CCV Dumped, Foil, AIH, and EBV, Pontoons All Missing... Rebuilt Transmission at 137k~AE w/Ford Pack~
  #22  
Old 07-11-2018, 08:41 AM
kcstreetracer's Avatar
kcstreetracer kcstreetracer is offline
Private
Member's Gallery
 
Join Date: Jan 2018
Posts: 27
Default

Quote:
Originally Posted by ToMang07 View Post
Fluid level good and all the air out of the lines?
Fluid level is good. I don't know about air in the lines. How do I check that?

Sent from my Pixel 2 XL using Tapatalk
__________________
2012 F250 SC | 12" FABTECH LIFT | 40x15.5 NITTO MUD GRAPPLERS | 20X12 FUEL MAVERICKS | NFAB STEPS | *** & EGR ******D | 5" AFE DP BACK EXHAUST | S&B CAI | AFE HOT & COLD SIDE | PCV REROUTE | LONGHORN TRACTION BARS | SCT LIVEWIRE W/ TUNES FROM TYRANT
  #23  
Old 07-11-2018, 08:41 AM
kcstreetracer's Avatar
kcstreetracer kcstreetracer is offline
Private
Member's Gallery
 
Join Date: Jan 2018
Posts: 27
Default

Quote:
Originally Posted by Mhatlen View Post
Is it slipping on shifts through the gears with power or skipping?
Yes a bit of both

Sent from my Pixel 2 XL using Tapatalk
__________________
2012 F250 SC | 12" FABTECH LIFT | 40x15.5 NITTO MUD GRAPPLERS | 20X12 FUEL MAVERICKS | NFAB STEPS | *** & EGR ******D | 5" AFE DP BACK EXHAUST | S&B CAI | AFE HOT & COLD SIDE | PCV REROUTE | LONGHORN TRACTION BARS | SCT LIVEWIRE W/ TUNES FROM TYRANT
  #24  
Old 07-12-2018, 09:27 AM
BigRed97's Avatar
BigRed97 BigRed97 is offline
Sergeant
Member's Gallery
 
Join Date: Aug 2011
Location: Saugus MA
Posts: 466
Default

Try doing a adaptive reset
__________________
2016 6.7 CCLB- 4.5" lift with 37s, weight watchers, GH tunes and stg2 intake from No Limit
  #25  
Old 07-12-2018, 11:56 AM
blacksmoke.r.us's Avatar
blacksmoke.r.us blacksmoke.r.us is offline
Sergeant
Member's Gallery
 
Join Date: Mar 2012
Location: Santa Fe NM
Posts: 155
Default

I lost all the fluid in my trans one time and it took a lot of driving to purge the sytem fully. I also thought I blew my trans.

When in drive the trans would go automatically in to 5th but I had reverse. I drove around in reverse to purge the system of air and heat up the fluid. Finally as the trans got some heat in it, it started to shift in drive, still erractic but better. After I got a few foward gears I got some more heat in it and the more I drove it the better it got and soon after it was normal. Shifting threw all the gears like it should.

I think the trans has to be at a normal operating temp to open up the all the valves in the valve body. Then you will be able to purge the system fully.

Remember to keep adding fluid as the trans purges the air, just try and not overfill. Also when doing this dont abuse it as it could lead to some other issues

Last edited by blacksmoke.r.us; 07-12-2018 at 12:07 PM.
  #26  
Old 07-12-2018, 01:32 PM
kcstreetracer's Avatar
kcstreetracer kcstreetracer is offline
Private
Member's Gallery
 
Join Date: Jan 2018
Posts: 27
Default

Quote:
Originally Posted by blacksmoke.r.us View Post
I lost all the fluid in my trans one time and it took a lot of driving to purge the sytem fully. I also thought I blew my trans.

When in drive the trans would go automatically in to 5th but I had reverse. I drove around in reverse to purge the system of air and heat up the fluid. Finally as the trans got some heat in it, it started to shift in drive, still erractic but better. After I got a few foward gears I got some more heat in it and the more I drove it the better it got and soon after it was normal. Shifting threw all the gears like it should.

I think the trans has to be at a normal operating temp to open up the all the valves in the valve body. Then you will be able to purge the system fully.

Remember to keep adding fluid as the trans purges the air, just try and not overfill. Also when doing this dont abuse it as it could lead to some other issues
It's at Ford getting diagnosed. Of course their saying burnt clutches. They probably are knowing my luck. It's been driven a few hundred miles, I would think the air is worked out by now

Sent from my Pixel 2 XL using Tapatalk
__________________
2012 F250 SC | 12" FABTECH LIFT | 40x15.5 NITTO MUD GRAPPLERS | 20X12 FUEL MAVERICKS | NFAB STEPS | *** & EGR ******D | 5" AFE DP BACK EXHAUST | S&B CAI | AFE HOT & COLD SIDE | PCV REROUTE | LONGHORN TRACTION BARS | SCT LIVEWIRE W/ TUNES FROM TYRANT
  #27  
Old 07-12-2018, 03:36 PM
doo dah's Avatar
doo dah doo dah is offline
Sergeant
Member's Gallery
 
Join Date: Jul 2015
Location: San Antonio
Posts: 332
Default

I have a Suncoast 750hp kit in mine. Also got their torque converter and billet flexplate with the kit. My truck has 575 & 1100 at the wheels so way more than I need but I can beat on it and not worry about it. Mine was pulled and rebuilt, if you are going to swap Midwest might be a better option.
__________________
2012 F350 CC LB 4x4 Lariat. MiniMaxx with TSD tunes, 5" exhaust, Industrial Injection S363 single turbo kit.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:51 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd