Go Back   PowerStrokeArmy > Power Strokes > 6.7 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 06-14-2018, 06:19 PM
FORDPWR's Avatar
FORDPWR FORDPWR is offline
Private
Member's Gallery
 
Join Date: Jul 2016
Posts: 22
Default White smoke at idle/converter noise

Iv been having so many problems Iím ready to do an insurance claim. Anyway on my ******d 12 with ppei tunes and 126k miles I have developed a random white/grey haze at idle. When I punch it itís greyish then black and fine until I let idle for 5 or more mins.

Also I noticed when truck is in park or neutral there is a slight dry bearing noise coming from the front of the trans. If I put it in gear or reverse the noise goes away. Itís not very loud but Iím very picky with small noises. Is this something I should be worried about?

Truck runs awesome except for my shifting and tune revisions Iím dealing with but thatís a different problem. All fluids stay the same level and temps all look normal. Kind of freaking out and donít know what else to look for. Any help would be greatly appreciated
  #2  
Old 06-18-2018, 02:39 PM
FORDPWR's Avatar
FORDPWR FORDPWR is offline
Private
Member's Gallery
 
Join Date: Jul 2016
Posts: 22
Default

Anyone? I can’t figure it out and neither can the shop. It hasn’t used any fluids yet either.
  #3  
Old 06-26-2018, 07:45 PM
BIG JUICE's Avatar
BIG JUICE BIG JUICE is offline
Lieutenant
Member's Gallery
 
Join Date: Jun 2013
Location: Apollo beach FLA
Posts: 686
Default

turbo leaking oil?
__________________
2015 F250 platinum, flopro 5", jones turbine 5050xl, polished No Limit stage 2/pg 7 and prefilter intake, h&s intercooler pipe(throttlebody-gone) and half ccv reroute, jenny craig, sotf gear hedd tune, Rigid DOT fogs, Chinese 40" radius led, amp steps, weathertechs, edge cts2, titan tank, dieselsite fuel filter, blue ox gooseneck, Hellwig bars, retrofit projectors, linex plat, retrax cover,full Carli 2.5" backcountry,fox 2.0 res shocks, toyo rt 37", OUO ala & bars
  #4  
Old 06-26-2018, 07:46 PM
BIG JUICE's Avatar
BIG JUICE BIG JUICE is offline
Lieutenant
Member's Gallery
 
Join Date: Jun 2013
Location: Apollo beach FLA
Posts: 686
Default

white is usually not fuel
__________________
2015 F250 platinum, flopro 5", jones turbine 5050xl, polished No Limit stage 2/pg 7 and prefilter intake, h&s intercooler pipe(throttlebody-gone) and half ccv reroute, jenny craig, sotf gear hedd tune, Rigid DOT fogs, Chinese 40" radius led, amp steps, weathertechs, edge cts2, titan tank, dieselsite fuel filter, blue ox gooseneck, Hellwig bars, retrofit projectors, linex plat, retrax cover,full Carli 2.5" backcountry,fox 2.0 res shocks, toyo rt 37", OUO ala & bars
  #5  
Old 06-28-2018, 12:01 AM
rrkroll rrkroll is offline
Private
Member's Gallery
 
Join Date: Jun 2018
Posts: 10
Default

Just a hunch, but the front of your transmission is near the back of your turbo, It isnít a fun job but I would consider checking the turbo for shaft play. Especially since it is a 2012, the bearings are known to go out and when they do it will smoke white smoke at idle. In fact, mine just did this but I let it go too long and the bearings blew apart and the shaft broke in half, fix it before that happens.

Also, if it is the turbo I would recommend getting the 2015 upgrade so this doesnít happen again.


Sent from my iPhone using Tapatalk
  #6  
Old 06-28-2018, 08:58 AM
lincolnlocker's Avatar
lincolnlocker lincolnlocker is offline
General
Member's Gallery
 
Join Date: May 2011
Location: central michigan
Posts: 24,775
Default

Quote:
Originally Posted by BIG JUICE View Post
white is usually not fuel
Since when?

live life full throttle
__________________
00,f350,4x4,cc,drw, under the knife
01 rclb zf6,4x4,srw,ts tunes,bfaf,4"exhaust, 3800lb dd clutch
12,f350,4x4,cclb,srw, rudys/punch it d3lete tunes, donaldson bfaf.
god bless america and the farmer who feeds your fat ass
  #7  
Old 07-09-2018, 11:28 AM
FORDPWR's Avatar
FORDPWR FORDPWR is offline
Private
Member's Gallery
 
Join Date: Jul 2016
Posts: 22
Default

Still have not figured it out. Shop said the turbo looks great and it’s still not using fluids. Also it could be my imagination but since I changed my tune it doesn’t do it as much or often.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:27 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd