Go Back   PowerStrokeArmy > Power Strokes > 6.7 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 06-06-2019, 08:50 AM
HobbyStock62's Avatar
HobbyStock62 HobbyStock62 is offline
Sergeant
Member's Gallery
 
Join Date: Dec 2012
Location: Mpls, MN
Posts: 475
Default 2015 Cooled Seat, Back Not Working?

Are the backs of these seats cooled too? The base of the seat is the only thing that cools on mine, I dont get any on the back of the seat, is that supposed to be cooled as well? If so, anyone know the fix for that? I havent looked at it, or taken anything apart yet.
__________________
I am a ginger.
  #2  
Old 06-07-2019, 10:18 PM
webb06's Avatar
webb06 webb06 is offline
Colonel
Member's Gallery
 
Join Date: Aug 2012
Location: Seneca, MO
Posts: 3,748
Default

My 2012 only cools out the bottom cushion I believe.


Sent from my iPhone using Tapatalk
  #3  
Old 06-10-2019, 06:04 AM
HeavyAssault's Avatar
HeavyAssault HeavyAssault is offline
Major
Member's Gallery
 
Join Date: May 2011
Location: Middle, VA
Posts: 1,262
Default

Yes, the back should be getting cooling flow. I'd make sure the intake area isn't getting clogged.
  #4  
Old 06-10-2019, 03:34 PM
HobbyStock62's Avatar
HobbyStock62 HobbyStock62 is offline
Sergeant
Member's Gallery
 
Join Date: Dec 2012
Location: Mpls, MN
Posts: 475
Default

I replaced that filter under my seat with the updated plastic piece. Not an actual filter. Still no cooling in the back. Ill have to look at the seat when I have some time and see if a vent going to the back came off or whats happening.
__________________
I am a ginger.
  #5  
Old 06-10-2019, 08:19 PM
08Monster's Avatar
08Monster 08Monster is offline
Major
Member's Gallery
 
Join Date: Sep 2013
Posts: 1,869
Default

None of mine have cooled on the back, I've had 3 6.7s. All 14s if it makes a difference

Sent from my XT1585 using Tapatalk
  #6  
Old 06-12-2019, 08:28 AM
lincolnlocker's Avatar
lincolnlocker lincolnlocker is offline
General
Member's Gallery
 
Join Date: May 2011
Location: central new york
Posts: 26,042
Default

I need to double check mine. I could have swore air comes out of the back rest. Unless cooling my ass makes that much difference on back sweat. Lol. When i run it my back stays cool too...

live life full throttle
__________________
00,f350,4x4,cc,drw. Sold... good bye ole girl. I will miss you
15,f350,4x4,cclb, not stock
god bless america and the farmer who feeds your fat ass
  #7  
Old 06-12-2019, 10:09 AM
dsberman94's Avatar
dsberman94 dsberman94 is offline
General
Member's Gallery
 
Join Date: Oct 2013
Location: Pennsylvania
Posts: 10,817
Default

Air comes out of the back rest in my 14 f150. I can easily hear the fan running back there when I turn it on. Kinda sounds like it right behind my head.
__________________
02 F250 7.3 Crew Cab Short Bed Lariat
PHP Hydra, Ge4rhead tunes, Edge insight CTS monitor
Mild Trans Build, Dual disc TC
GTP38R, T500, PIS 175/80s in the engine. waiting to see rods one day

Turned 200k miles 1/18/2015
  #8  
Old 06-12-2019, 10:46 AM
lincolnlocker's Avatar
lincolnlocker lincolnlocker is offline
General
Member's Gallery
 
Join Date: May 2011
Location: central new york
Posts: 26,042
Default

Yes, air does come out of the back of my seat in my 15. Im sitting in it now. Lol

live life full throttle
__________________
00,f350,4x4,cc,drw. Sold... good bye ole girl. I will miss you
15,f350,4x4,cclb, not stock
god bless america and the farmer who feeds your fat ass
  #9  
Old 06-12-2019, 01:52 PM
HobbyStock62's Avatar
HobbyStock62 HobbyStock62 is offline
Sergeant
Member's Gallery
 
Join Date: Dec 2012
Location: Mpls, MN
Posts: 475
Default

Alright, I am assuming that a vent must have come off somewhere. Ill try to dig into it when I have time on Sunday.
__________________
I am a ginger.
  #10  
Old 06-12-2019, 10:19 PM
08Monster's Avatar
08Monster 08Monster is offline
Major
Member's Gallery
 
Join Date: Sep 2013
Posts: 1,869
Default

Quote:
Originally Posted by HobbyStock62 View Post
Alright, I am assuming that a vent must have come off somewhere. Ill try to dig into it when I have time on Sunday.
Let me know, mine is obviously off as well.

Sent from my XT1585 using Tapatalk
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:59 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Designed by Military Ltd