Go Back   PowerStrokeArmy > Power Strokes > 6.7 Aftermarket

Reply
 
Thread Tools Display Modes
  #1  
Old 03-25-2015, 09:02 PM
UNBROKEN's Avatar
UNBROKEN UNBROKEN is offline
Colonel
Member's Gallery
 
Join Date: May 2011
Posts: 2,760
Default NOX module got me.

Popped the P0100 and U0106 codes and lost the glow plugs. I thought I unplugged those things....guess not. Just a warning to those about to ******...don't miss that connection.
  #2  
Old 03-25-2015, 09:59 PM
Mpoage's Avatar
Mpoage Mpoage is offline
Major
Member's Gallery
 
Join Date: May 2011
Location: OKC, OK
Posts: 1,017
Default

I've had that happen on a few trucks including mine. I think water and dirt gets into the connector on top of the nox module and it shorts out.
__________________
2013 Ford F-250 Platinum 4X4 6.7 Powerstroke

H&S Mini Maxx (MCC From ********)
5 In. Flo-Pro
Absolute EGR ******
  #3  
Old 03-25-2015, 10:17 PM
drunk on diesel drunk on diesel is offline
Sponsor
Member's Gallery
 
Join Date: Sep 2011
Posts: 4,184
Default

Is this unique to the 15's? Is it just one module or are there multiples? I know the 15's have that 3rd O2 in the tailpipe.

Just curious. I haven't used an X4 on a 6.7 yet
  #4  
Old 03-26-2015, 07:52 AM
BuiltPowerStrokeTough's Avatar
BuiltPowerStrokeTough BuiltPowerStrokeTough is offline
Lieutenant
Member's Gallery
 
Join Date: Mar 2014
Location: Central Illinois
Posts: 628
Default

Quote:
Originally Posted by UNBROKEN View Post
Popped the P0100 and U0106 codes and lost the glow plugs. I thought I unplugged those things....guess not. Just a warning to those about to ******...don't miss that connection.
Can you explain in more detail what you mean about what failed and why? I guess Ive never heard how a NOX sensor/module issue can make your glow plugs innoperable. I have a 2011 and I literally disconnected the NOX sensor connector from the NOX module and left the sensor in the ***. I also completed disconnected the NOX module from the main harness and removed the whole NOX module unit from the truck. The NOX module has been in my garage since I ******d it a couple years ago and no problems.
__________________
Nathan

2017 F350 6.7 PSD XLT, Bronze Fire Metallic CCSB
  #5  
Old 03-26-2015, 07:57 AM
UNBROKEN's Avatar
UNBROKEN UNBROKEN is offline
Colonel
Member's Gallery
 
Join Date: May 2011
Posts: 2,760
Default

I dunno why but apparently the NOX module, glow plugs and MAF are all on the same circuit. I meant to disconnect the modules from the main harness...just forgot about it I guess. I got the codes and lost the glow plugs...that's the tell-tale sign that the module shorted out. I even put dielectric grease in the connection when I unplugged the sensor....still shorted out.
I'm gonna pull them off today and throw a new fuse in...should be good to go.

Last edited by UNBROKEN; 03-26-2015 at 08:07 AM.
  #6  
Old 03-26-2015, 08:46 AM
drunk on diesel drunk on diesel is offline
Sponsor
Member's Gallery
 
Join Date: Sep 2011
Posts: 4,184
Default

yeah, I can see how if they're all on the same VREF, if you short one out or short out the NOx module via a sensor lead how it could cause some issues down the chain...

Thanks for the PSA, Rico
  #7  
Old 03-26-2015, 08:36 PM
UNBROKEN's Avatar
UNBROKEN UNBROKEN is offline
Colonel
Member's Gallery
 
Join Date: May 2011
Posts: 2,760
Default

So just out of curiosity I unplugged the rear module first, threw in a new fuse and immediately popped it. Unplugged the front module, threw in another fuse and all is well.
The plug for the sensor on both was/is full of dielectric grease so I have no idea why it had issues.
  #8  
Old 03-29-2015, 08:25 PM
Jacob @ No Limit's Avatar
Jacob @ No Limit Jacob @ No Limit is offline
Sponsor
Member's Gallery
 
Join Date: Jul 2014
Location: Indiana
Posts: 746
Default

This happened to me today. I've been ******d for 9k miles.
__________________
No Limit Fabrication
Sales & Support

Text/Call (317)452-5522


- 2015 F-350 Platinum CCLB 4x4 - No Limit, Midwest, H&S, and Maryland Diesel under the hood

- 2015 F-350 Lariat CCLB Dually 4x4 - No Limit & H&S under the hood
  #9  
Old 03-29-2015, 09:20 PM
UNBROKEN's Avatar
UNBROKEN UNBROKEN is offline
Colonel
Member's Gallery
 
Join Date: May 2011
Posts: 2,760
Default

Hell mine didn't make it 1000 miles before it happened.
__________________
2014 F250 XLT
Work truck
2015 F250 Platinum
Play truck
  #10  
Old 03-29-2015, 09:27 PM
Jacob @ No Limit's Avatar
Jacob @ No Limit Jacob @ No Limit is offline
Sponsor
Member's Gallery
 
Join Date: Jul 2014
Location: Indiana
Posts: 746
Default

That's crazy. I'm going to remove the modules and Def tank and lines when it gets warm.
__________________
No Limit Fabrication
Sales & Support

Text/Call (317)452-5522


- 2015 F-350 Platinum CCLB 4x4 - No Limit, Midwest, H&S, and Maryland Diesel under the hood

- 2015 F-350 Lariat CCLB Dually 4x4 - No Limit & H&S under the hood
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:16 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd