Go Back   PowerStrokeArmy > Power Strokes > 7.3 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 07-30-2017, 07:50 PM
greyford1979's Avatar
greyford1979 greyford1979 is offline
Major
Member's Gallery
 
Join Date: Jan 2013
Location: Copley,Ohio
Posts: 1,215
Default No cruise control

Well I have no cruise in my 2000 and I have searched all over the net, and pretty much finding the same thing. My switch on the brake booster is new, my buttons on the steering wheel are new, but no cruise. All brake lights work, horn works, speedo works and didn't really see any loose connections. Could the clock spring still be bad even though the horns work and have no air bag light on? Is there a separate module on these that controls the cruise? Definitely not trying to drive this thing 11 hours without cruise on vacation at the end of September lol.
  #2  
Old 07-30-2017, 07:52 PM
79jasper's Avatar
79jasper 79jasper is offline
Major
Member's Gallery
 
Join Date: Feb 2012
Location: skiatook, Oklahoma
Posts: 2,149
Default

Cruise is in the pcm.
Start checking fuses. There is a cruise fuse.
Do you have AE?

Sent from my SAMSUNG-SM-G890A using Tapatalk
__________________
1994 F350 7.3 PSD 4X4 ZF5 DUALLY
PHP HYDRA, 6637, 3-4 DP TO STRAIGHT 4 BEHIND THE TIRE, 1.0 EXHAUST HOUSING, DIY D66 TURBO, FUGA E-FUEL, EBPV Removal. Cooper discoverer AT/3'S.
2010 VW JETTA TDI DSG Kerma tune. Hankook ventus v2 concept 2.

http://badges.fuelly.com/images/sig-us/174421.png
http://badges.fuelly.com/images/sig-us/420711.png
  #3  
Old 07-30-2017, 08:01 PM
greyford1979's Avatar
greyford1979 greyford1979 is offline
Major
Member's Gallery
 
Join Date: Jan 2013
Location: Copley,Ohio
Posts: 1,215
Default

Quote:
Originally Posted by 79jasper View Post
Cruise is in the pcm.
Start checking fuses. There is a cruise fuse.
Do you have AE?

Sent from my SAMSUNG-SM-G890A using Tapatalk
I have checked all fuses and yes I do have AE.
  #4  
Old 07-30-2017, 08:03 PM
Magnum PD's Avatar
Magnum PD Magnum PD is online now
General
Member's Gallery
 
Join Date: May 2011
Location: VA
Posts: 7,928
Default

Nothing to do with pedal assembly?
__________________
96 F-350 RC 4x4 Hypermax Rods, PIS 300/200s Dyno Proven tunes, Garrett GT4294, Beans IDM, ARP head & main, girdle, half filled block, DI cam, ceramic coated bowls, anti-friction skirts, Haldex pump over Honey Badger Jr, Diesel site High volume lpop, Billet intake Plenums, Dual SD pumps, Fluidampner, beehive springs, cosmetic head gaskets, Inconel valves, hardend guides, Ported and polished heads by me, home made RR fuel, 5 speed tranny, with SB 3600 DxD. Snow water meth.
  #5  
Old 07-30-2017, 08:26 PM
79jasper's Avatar
79jasper 79jasper is offline
Major
Member's Gallery
 
Join Date: Feb 2012
Location: skiatook, Oklahoma
Posts: 2,149
Default

I'm not sure the specifics, but you can test the buttons with AE.

Sent from my SAMSUNG-SM-G890A using Tapatalk
__________________
1994 F350 7.3 PSD 4X4 ZF5 DUALLY
PHP HYDRA, 6637, 3-4 DP TO STRAIGHT 4 BEHIND THE TIRE, 1.0 EXHAUST HOUSING, DIY D66 TURBO, FUGA E-FUEL, EBPV Removal. Cooper discoverer AT/3'S.
2010 VW JETTA TDI DSG Kerma tune. Hankook ventus v2 concept 2.

http://badges.fuelly.com/images/sig-us/174421.png
http://badges.fuelly.com/images/sig-us/420711.png
  #6  
Old 07-30-2017, 08:50 PM
PDT1081's Avatar
PDT1081 PDT1081 is offline
Major
Member's Gallery
 
Join Date: Jun 2011
Location: Bowling Green, OH
Posts: 1,271
Default

Quote:
Originally Posted by greyford1979 View Post
Well I have no cruise in my 2000 and I have searched all over the net, and pretty much finding the same thing. My switch on the brake booster is new, my buttons on the steering wheel are new, but no cruise. All brake lights work, horn works, speedo works and didn't really see any loose connections. Could the clock spring still be bad even though the horns work and have no air bag light on? Is there a separate module on these that controls the cruise? Definitely not trying to drive this thing 11 hours without cruise on vacation at the end of September lol.
Auto or manual?
  #7  
Old 07-30-2017, 09:35 PM
greyford1979's Avatar
greyford1979 greyford1979 is offline
Major
Member's Gallery
 
Join Date: Jan 2013
Location: Copley,Ohio
Posts: 1,215
Default

Quote:
Originally Posted by PDT1081 View Post
Auto or manual?
Auto
  #8  
Old 07-30-2017, 10:48 PM
dmd's Avatar
dmd dmd is offline
Lieutenant
Member's Gallery
 
Join Date: Jul 2011
Posts: 531
Default

If it has the fuse recall, check the pigtail fuse...

Also check if the parking brake is released all the way.
__________________
2k, F350 SuperCruzer, 7.3L Diesel, Auto trans, 4x4, 6-pos GH Tunes, S&B cold air intake, 4-inch turbo-back exhaust, Garrett 38r, Adrenaline HPOP, BTS Transmission, Swamps IDM(broke, back to stock), Single Shot Injectors, in-tank and pre-pump mod, Heater valve mod, X-car sound panel mod
  #9  
Old 07-31-2017, 06:23 PM
greyford1979's Avatar
greyford1979 greyford1979 is offline
Major
Member's Gallery
 
Join Date: Jan 2013
Location: Copley,Ohio
Posts: 1,215
Default

Quote:
Originally Posted by dmd View Post
If it has the fuse recall, check the pigtail fuse...

Also check if the parking brake is released all the way.
Fuse recall? The pigtail at the end of the brake booster? And yes the parking brake is all the way off.
  #10  
Old 07-31-2017, 06:43 PM
dmd's Avatar
dmd dmd is offline
Lieutenant
Member's Gallery
 
Join Date: Jul 2011
Posts: 531
Default

If you had the cruise control recall they put a pigtail with a fuse in it that
is attached to the cutoff switch on the brake booster. The switch can catch
on fire if it shorts out and burn the truck down, or your house if parked in the
garage.
__________________
2k, F350 SuperCruzer, 7.3L Diesel, Auto trans, 4x4, 6-pos GH Tunes, S&B cold air intake, 4-inch turbo-back exhaust, Garrett 38r, Adrenaline HPOP, BTS Transmission, Swamps IDM(broke, back to stock), Single Shot Injectors, in-tank and pre-pump mod, Heater valve mod, X-car sound panel mod
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:14 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Designed by Military Ltd