Go Back   PowerStrokeArmy > Power Strokes > 6.4 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 01-14-2021, 10:02 AM
Able Able is offline
Private
Member's Gallery
 
Join Date: Jan 2021
Posts: 3
Default 6.4 after rebuild will not run

Hello everyone,

I came across this forum after researching my 2008 F250 6.4 after our rebuild will not run. Any help or suggestions would be great we are back up against a wall on this one:

Just to give you some history on this truck, we completely rebuilt the engine. Got it all back together, loaded tune, bled the fuel system and seemed to be running fine. drove out the drive to go on a test run and while driving down the drive when it shifted from 1st to 2nd it shut down. Drug it back to the shop and it had a code of lost communication with TCM. Troubleshoot that code and replaced TCM. Cleared codes and tried to start and would not start. It would crank fine and building fuel pressure but not fire the injectors. Starting checking CAN circuit wires and checking ECM. The truck started while we were checking systems and ran. Checked everything over and went for a test drive. Drove about 4 miles down the road and turned around. Everything was looking good, EGT was around 625-650 at 60MPH. was driving on a straight away and the engine shut down. Pulled back to the shop and started going through the wiring harness. Checked all plugs and CAN circuits between modules. Had batteries disconnected for entire time working on this. After checking all this I did an all system DTC scan. it came up with, did not read Instrument cluster, test manually. Went to TCM and did a scan and said , did not read Eng PCM, test manually, did not read Instrument Cluster. Went to Instrument and did a scan , It had a code B2A20 ING Stuck in start which i could not clear. it also said did not read Eng PCM. and a code B106E solid state driver disable due to short. When i did a scan from OBD II it said Did not read Eng. PCM , test manually. The truck was running when it came to the shop, i cant figure out what is going on. something in the computer isn't happy just cant nail it down. we have done same thing to other trucks ,Fords, Chevys, Dodges and have not ran into this. I don't want to start swaping parts just to swap parts. i want to figure out what happened. All help would be very much appreciated. Thanks.. Able
  #2  
Old 01-14-2021, 07:59 PM
Powerstroke Man 6.4's Avatar
Powerstroke Man 6.4 Powerstroke Man 6.4 is offline
Colonel
Member's Gallery
 
Join Date: Jan 2012
Posts: 4,029
Default

Quote:
Originally Posted by Able View Post
Hello everyone,

I came across this forum after researching my 2008 F250 6.4 after our rebuild will not run. Any help or suggestions would be great we are back up against a wall on this one:

Just to give you some history on this truck, we completely rebuilt the engine. Got it all back together, loaded tune, bled the fuel system and seemed to be running fine. drove out the drive to go on a test run and while driving down the drive when it shifted from 1st to 2nd it shut down. Drug it back to the shop and it had a code of lost communication with TCM. Troubleshoot that code and replaced TCM. Cleared codes and tried to start and would not start. It would crank fine and building fuel pressure but not fire the injectors. Starting checking CAN circuit wires and checking ECM. The truck started while we were checking systems and ran. Checked everything over and went for a test drive. Drove about 4 miles down the road and turned around. Everything was looking good, EGT was around 625-650 at 60MPH. was driving on a straight away and the engine shut down. Pulled back to the shop and started going through the wiring harness. Checked all plugs and CAN circuits between modules. Had batteries disconnected for entire time working on this. After checking all this I did an all system DTC scan. it came up with, did not read Instrument cluster, test manually. Went to TCM and did a scan and said , did not read Eng PCM, test manually, did not read Instrument Cluster. Went to Instrument and did a scan , It had a code B2A20 ING Stuck in start which i could not clear. it also said did not read Eng PCM. and a code B106E solid state driver disable due to short. When i did a scan from OBD II it said Did not read Eng. PCM , test manually. The truck was running when it came to the shop, i cant figure out what is going on. something in the computer isn't happy just cant nail it down. we have done same thing to other trucks ,Fords, Chevys, Dodges and have not ran into this. I don't want to start swaping parts just to swap parts. i want to figure out what happened. All help would be very much appreciated. Thanks.. Able
Was the cab off for the rebuild? check the shock tower connections (big ones)
__________________

No Limit Fabrication
Midwest Diesel & Auto
  #3  
Old 01-15-2021, 07:44 AM
Able Able is offline
Private
Member's Gallery
 
Join Date: Jan 2021
Posts: 3
Default

Not all the way I just took the front 6 out and loosened the back two to get enough room to put the engine back in
  #4  
Old 01-15-2021, 03:30 PM
Able Able is offline
Private
Member's Gallery
 
Join Date: Jan 2021
Posts: 3
Default

We have checked and rechecked those no change.

I think at this point I'm going to have the ECM flashed back to factory setting and push the tune back on. I think the truck had plug and play tune pushed on to it.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:21 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

Designed by Military Ltd