Go Back   PowerStrokeArmy > Power Strokes > 6.7 Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-15-2020, 11:45 AM
Texan6Seven Texan6Seven is offline
Corporal
Member's Gallery
 
Join Date: Jul 2014
Location: Ft Worth, TX
Posts: 79
Default Oil residue in intercooler piping

I’ve had the MPD budget 364.5 kit with full piping and CCV kit on my truck now for 100k miles. I did a boost leak test on the truck as it felt like it wasn’t running as well as it did when I initially installed the kit. Well, when I pulled the intake piping off the turbo inlet I found what I feel is more than usual oil residue on the turbo inlet. Anyhow, I did find a pinhole in the welding on the intake plenum where the two CNC parts are welded together. I pulled the cold side pipe off to get a good ground to TIG the pinhole up and also found oil residue in the intake plenum.

Where could I be getting oil residue from if all CC recirculation is bypassed?
__________________
2013 CCSB, 335k, Carli 4.5” Commuter with Deavers, ICON trac bar, Fox steering, V Rock 20x12, 35” Toyo RT, AmpPro stereo integration w/5V signal, Alpine amps, Image Dynamics 6.5” comp all around
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:22 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd