Go Back   PowerStrokeArmy > Power Strokes > 6.0 Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-21-2020, 06:21 AM
Smokin 6.0 Smokin 6.0 is offline
Lieutenant
Member's Gallery
 
Join Date: Jul 2012
Location: Indiana
Posts: 783
Default ICP issue ?

Having issues with my 05 randomly dieing. Most of the time itís right after I have let out of the throttle at low speeds or when itís sitting idle. It will start to act like itís gunna die and then recover and run fine and then sometimes it dies.. every time it restarts just fine. I have unplugged the ICP and driven it that way for awhile and it hasnít ever died. One time it started hard with the ICP unplugged kinda like it was starting to hydro lock and then it starts and there is a TON of white smoke that smells like raw fuel. Other times it started ok. Any thoughts I have access to a snap on that I can monitor and look for things but it will take me a few days to get it. Also if itís randomly dieing will live data tell me anything or do I have to be looking at it as the symptoms are happening.. thanks in advance
__________________
My Rig - 2005 CCSB F-250 Lariat - Stock
Wife's Rig - 2016 Z71 Tahoe on 22ís
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:06 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd