Go Back   PowerStrokeArmy > Power Strokes > 94-97 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 05-29-2020, 10:26 PM
chaselee's Avatar
chaselee chaselee is offline
Sergeant
Member's Gallery
 
Join Date: May 2016
Posts: 276
Default What's up with my blinker!?!?

Pulling into my hood this evening (witha cop behind me btw) I put in my right blinker and the arrow on the dash went solid green. A minute later I went to make a left turn and everything worked as it should. I have switchback LEDs in the front and led rear bulbs as well so I figured one of them had gone out or malfunctioned.

I got home and strated playing with it, thinking maybe I had a bad connection somewhere and couldn't figure it out. I swapped bulbs from side to side, the whole nine yards and nothing would make the right side blink. So I turned on the flashers and everything works as it should. So now I'm confused more than ever.

I turn off the flashers and try again. Left side blinks like normal, right side doesn't blink at all. While I was in there I pulled in the blinker knob (left side of the steering wheel, whatever's it's called) and the high beams would come on, but push it forward as to turn the high beams on for good and nothing.

My thought is something is going wrong in the switch/knob itself...is this a thing with these trucks? If so what's the fix? As if right now I have no right blinkers.
__________________
1996 CCSB Auto, John Wood VB, Dual disc TC, 4.10 gears, Irate efuel, super duty intercooler, BW 364.5 sxe turbo, 4" turbo back, AFE CAI, Full force 205/80 sticks, 1023 Hydra tunes, 4" lift d60 swap, 37" Maxxis razr MT.
  #2  
Old 05-30-2020, 12:54 PM
Bugman's Avatar
Bugman Bugman is offline
Major
Member's Gallery
 
Join Date: Aug 2011
Location: Gypsum, Co
Posts: 1,234
Default

Can you hear the flasher unit clicking or put your hand on it and feel it to see if it is working.

If you can't hear or feel it then I would suspect the multi function switch on the column.
__________________
96 F250 4x4 XLT, 5 speed, 4:10 rear end, gauges, Dale's HX hose, Dale's Tymar, downpipe, coolant filter, add a leaf, Luc clutch
  #3  
Old 05-30-2020, 01:39 PM
chaselee's Avatar
chaselee chaselee is offline
Sergeant
Member's Gallery
 
Join Date: May 2016
Posts: 276
Default

Yeah I went ahead and ordered a multi function switch being that the high beams won't work either. I figured that has to be it. My highs will flash, when you pull it back, but when you push it forward it doesn't do anything.
__________________
1996 CCSB Auto, John Wood VB, Dual disc TC, 4.10 gears, Irate efuel, super duty intercooler, BW 364.5 sxe turbo, 4" turbo back, AFE CAI, Full force 205/80 sticks, 1023 Hydra tunes, 4" lift d60 swap, 37" Maxxis razr MT.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:56 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Designed by Military Ltd