Go Back   PowerStrokeArmy > Power Strokes > 94-97 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 09-20-2012, 08:33 PM
96stacked&smoken's Avatar
96stacked&smoken 96stacked&smoken is offline
Major
Member's Gallery
 
Join Date: Jun 2011
Location: pekin ,indiana
Posts: 1,170
Default Frontend poping noise

Hey i have a ongoing problem that i cant find. It started several months ago when i turned the wheel hard it poped a little. Now it does it when i turn or go over big bumps and also when the frontend flexes. It has new tie rod ends, axle u-joints, and driverside wheel bearings. It doesnt always do it at the same position when i turn the wheel so i dont believe its the steering box.Steering is smooth also.Balljoints are tight. Please help.
__________________
96 obs ext.cablb 5speed, 3in dp,4in strait,7in stacks,php tunes,isspro gauges,ccv mod,shimmed fpr, modded fuel bowl,ebpv ******d,6637,custom front bumper,led 3rd brake,smoked tails,train horns, black moto metal 951's,33-12.50 bfg's,traction bars,ww2,ff 180/30's
08 edge 3.5 awd sel
13 xlt screw 5.0 4x4 f150
  #2  
Old 09-20-2012, 09:10 PM
Patrick Feeley's Avatar
Patrick Feeley Patrick Feeley is offline
Sergeant
Member's Gallery
 
Join Date: Aug 2011
Location: Tehachapi, CA
Posts: 346
Default

Here's the old stanby trick (and don't laugh ... try it!): Tighten all the fender bolts along the top edges inside the engine compartment. Other than that, you could possibly have a bad rivet on the frame (TSB attached). Cheers!
Attached Files
File Type: pdf TSB 97-3-10.pdf (110.4 KB, 316 views)
__________________
1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
  #3  
Old 09-20-2012, 09:20 PM
JD3020's Avatar
JD3020 JD3020 is offline
Colonel
Member's Gallery
 
Join Date: May 2011
Location: Farmersville/Dayton, Oh
Posts: 3,995
Default

My truck does the same, and getting worse everyday. I'm just figuring its worn out spring or pivot bushings. Should try driving through a corn field hauling grain sometime in my truck, damn front end sounds like its about to fall off. Drives as straight as an arrow though, only issue is there is a shake in the steering wheel as i think one tire threw a weight and is out of balance.
__________________
Jimmy
2014 F-250 XLT, 68k, H&S IC pipe, Tyrant tunes and deleeted
97 F-250 ECLB 7.3/E4OD/4wd, 215k miles: FFD 250/200%'s, Swamps IDM, built trans. Built and tuned by me
01 F-450 crew cab, XLT ZF-6 7.3: tuned, intake, exhaust, 310k miles
05 Jeep Liberty diesel, tuned, EGR deleet
  #4  
Old 09-20-2012, 09:58 PM
Stroker#66 Stroker#66 is offline
Sergeant
Member's Gallery
 
Join Date: May 2011
Location: Cincinnati
Posts: 330
Default

Mine was making popping noises and it ended uP being the front spring shackle bushings
__________________
1997 ferd
400s,billet rods,s475
  #5  
Old 09-20-2012, 10:08 PM
kadeninabnitt's Avatar
kadeninabnitt kadeninabnitt is offline
Lieutenant
Member's Gallery
 
Join Date: May 2011
Location: Martinsville, IN
Posts: 731
Default

Quote:
Originally Posted by Stroker#66 View Post
Mine was making popping noises and it ended uP being the front spring shackle bushings
__________________
97 f250 hd 4x4 dually axle swap flatbed zf6 swap CAI DP dual exhaust
  #6  
Old 09-21-2012, 08:17 AM
Tom S's Avatar
Tom S Tom S is offline
Mod Squad
Member's Gallery
 
Join Date: May 2011
Posts: 3,366
Default

Mine had the huck rivet repair done under warranty. It would pop if you were turning the wheel hard at low speed or turning and going over a bump like pulling into a driveway.

In addition to what was mentioned I would also check the torque on my U-bolts and spring bolts as part of the process. Do you have a feel for where the pop noise is?

I am going to stick this thread to move into the library later as the TSB Patrick posted up is excellent.
__________________
1996 F250 Powerstroke 4X4 AUTO
DP-Tuner F-6 chip live tuned, BTS Transmission, Garrett 38R Turbo, Swamps Injectors 150cc, electric fuel,
Banks Intercooler, Reflexxions Cowl Hood, 17 degree HPOP, 4" Stainless Magnaflow &
Aeroturbine exhaust, Aeroforce OBD Scan Gauge, Truxedo tonneau cover
Dana 60 Precision Metal Fab RSK and SD Springs
  #7  
Old 09-21-2012, 08:23 AM
rat49f6's Avatar
rat49f6 rat49f6 is offline
Major
Member's Gallery
 
Join Date: May 2011
Location: Vernon,NJ
Posts: 1,259
Default

Subbed...mine does this and I can't view tsb from my phone

Sent from my T-Mobile G2 using Xparent Green Tapatalk 2
  #8  
Old 09-21-2012, 08:47 PM
96stacked&smoken's Avatar
96stacked&smoken 96stacked&smoken is offline
Major
Member's Gallery
 
Join Date: Jun 2011
Location: pekin ,indiana
Posts: 1,170
Default

Tsb is very inersesting, iv tried to narrow it down by spraying wd40 on anything that moves and makeing sure the u- bolts are tight. The spring bushings do look a lil rough tho. Its very annoying and i want to make sure it isnt serious.
__________________
96 obs ext.cablb 5speed, 3in dp,4in strait,7in stacks,php tunes,isspro gauges,ccv mod,shimmed fpr, modded fuel bowl,ebpv ******d,6637,custom front bumper,led 3rd brake,smoked tails,train horns, black moto metal 951's,33-12.50 bfg's,traction bars,ww2,ff 180/30's
08 edge 3.5 awd sel
13 xlt screw 5.0 4x4 f150
  #9  
Old 09-21-2012, 11:33 PM
Wes Lewis's Avatar
Wes Lewis Wes Lewis is offline
Sergeant
Member's Gallery
 
Join Date: Mar 2012
Location: Pittsburgh PA
Posts: 311
Default

Mine does it also, I'm pretty sure its where the I beams are bolted to the crossmember. Haven't looked at it yet

Seems from everyone's sig it's a f-250 thing?
__________________
96 Passat Tdi
88 Mustang
96 F-250
  #10  
Old 10-26-2012, 09:36 PM
Pstroke96's Avatar
Pstroke96 Pstroke96 is offline
Lieutenant
Member's Gallery
 
Join Date: May 2011
Location: Connecticut
Posts: 695
Default

check your sway and track bar bushings as well. i had a simiar issue turned out the shot bushings were the culprit
__________________
96 F350 reg cab 4X4
260,000 miles and counting
tymar intake
5 inch straight pipe
cale's tunes
isspro ev2 gauges
rigid industries light bar and D2's
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:38 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd