Go Back   PowerStrokeArmy > Power Strokes > 94-97 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 10-17-2017, 07:49 PM
501 96 7.3's Avatar
501 96 7.3 501 96 7.3 is offline
Private
Member's Gallery
 
Join Date: Jan 2015
Location: Arkansas
Posts: 27
Default Power steering leak

I put 2 new o-rings and a plastic ring on the high pressure line going into the reservoir, still leaked. Found out the hard line moves in and out of the fitting about 1/4". Anyone know a fix?
Attached Images
File Type: jpg IMG_5369.jpg (10.9 KB, 19 views)
__________________
1997 f350 cclb 4x4 315/75/16. 4.10's zf 5. Rosewood 200/30. Efuel 3" SD plenum's. Irate T4 s366 6.0 factory intercooler. T500. Isspro egt boost. Dp Infinity. TS 6 gear head
  #2  
Old 10-18-2017, 01:06 PM
rusty1161 rusty1161 is offline
Lieutenant
Member's Gallery
 
Join Date: Jun 2011
Location: Whittier, CA
Posts: 820
Default

The only successful fix I’ve had is replacing the whole line with a new one.

Rusty
__________________
1997 F250 CC/SB 7.3 PSD 4X4 XLT, 363SXE, PIS 160/30, John Wood Towmaster, 3" RSK, 260,000 miles
  #3  
Old 10-18-2017, 01:46 PM
dmd's Avatar
dmd dmd is offline
Lieutenant
Member's Gallery
 
Join Date: Jul 2011
Location: Denton, TX
Posts: 611
Default

Similar issue on my 2000. Seems every time the wife drives the truck something
breaks. This time the power line blew. Same fix, had to replace the line.

Church parking lot got an oiling, and I was able to get clean fluid in the system...
__________________
2k, F350 SuperCruzer, 7.3L Diesel, Auto trans, 4x4, GH Tunes w/190/30s, S&B cold air intake, 4-inch turbo-back exhaust, Garrett 38r, Adrenaline HPOP, BTS Transmission w/6.0 cooler, Swamps IDM(broke, back to stock), in-tank and pre-pump mod, Heater valve mod, X-car sound panel mod
  #4  
Old 10-18-2017, 05:21 PM
79jasper's Avatar
79jasper 79jasper is offline
Major
Member's Gallery
 
Join Date: Feb 2012
Location: skiatook, Oklahoma
Posts: 2,465
Default

Yeah, just replace the line.
Mine blew the hose out of the fitting. The nut stayed and everything. Lol

Sent from my SM-G892A using Tapatalk
__________________
2003 F250 KR SCSB FX4
Depleted, studded, airdog (which isn't currently hooked up), fass regulated return, airaide, 4 inch straight pipe with mbrp muffler(so on to go), glowchit pyro, fuel, boost, and trans temp. (Of course don't work lol) Hercules terra track A/T2 315/70/17.
2013 Honda pilot Touring
http://badges.fuelly.com/images/sig-us/778639.png
http://badges.fuelly.com/images/sig-us/776628.png
  #5  
Old 10-18-2017, 08:34 PM
501 96 7.3's Avatar
501 96 7.3 501 96 7.3 is offline
Private
Member's Gallery
 
Join Date: Jan 2015
Location: Arkansas
Posts: 27
Default

Thanks for the replies, new line it is.
__________________
1997 f350 cclb 4x4 315/75/16. 4.10's zf 5. Rosewood 200/30. Efuel 3" SD plenum's. Irate T4 s366 6.0 factory intercooler. T500. Isspro egt boost. Dp Infinity. TS 6 gear head
  #6  
Old 10-20-2017, 09:23 PM
rrchlin rrchlin is offline
Corporal
Member's Gallery
 
Join Date: Aug 2017
Posts: 80
Default

my new advance-auto lines leak out of the fitting at the steering box. you can move em around.. not a 1/4" but they leak. I think I'm going to take them back now while I have the fender off.

1st few days running it after dana 60 swap I leaked enough fluid to lose power steering and help send me into a death wobble.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:23 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd