Go Back   PowerStrokeArmy > Non - Specific > Project Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-24-2015, 12:24 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default 7.3/ZF6 Shorty.

Here's another shorty for the books. Just reserving my place for whats to come.


I picked up a 2wd 2000 F250 RCLB back in mid May of this year. 2 owner, 82K miles, new clutch, NOT WHITE and best of all a ZF6 behind it! I just had to have it. Drove out to Phoenix area with the girlfriend to pick it up. Drove it around a bit but I already had my CCLB ZF6 6.4 and a CCLB 6.0 that were my daily drivers so this one just sat in the driveway for a few months.

Here she is just as I bought it with my other trucks.



Slowly added a few things to it in between things I was doing to my other trucks.

First few things to go on were a set of aftermarket Harley 05+ headlights. The XL orange lights had to go.








Next was a stereo.

For the double DIN I went with a Pioneer AVH-X5600BHS
2-DIN Multimedia DVD Receiver with 7" WVGA Touchscreen Display(I have had this style in my past few trucks. The layout and display is awesome functionality is great, and the best feature is the Bluetooth audio streaming)



Went with something small and powerful enough for such a small cab so i went with a single PIONEER TS-SW2502S4 10-Inch, 1.200 Watts Shallow-Mount sub

4) New Kenwood KFC-C6895PS 6x8" 720 Watt 3-Way Car Audio Coaxial Speakers

BOSS Audio R6002 Riot 1200-watts Full Range Class Amp



Pretty good little setup. Ran something similar in my 6.4 and was happy with it.

Next I added a ACC gray carpet kit and OEM Ford all weather floor mats.


Last edited by slowcoupe; 11-24-2015 at 12:50 PM.
  #2  
Old 11-24-2015, 12:40 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

Took a break from the interior as i couldn't find seats or anything else I was looking for.

Happened to find a DJM 5'" rear shackle kit locally on craigslist.(what're the chances of that?!) Since i had torn the truck down to start the frame shortening I figure what better time to install the rear shackle kit.


Ended up setting the kit at the lowest drop and removing my overload spring and one leaf from the pack. This may change later when I add the front arms so that it will sit level. Installed as suggested by other posts the Bilstein 33-185590 rear shocks

Started the install in the afternoon and finished just after dark right before torrential downpour hit us here in Vegas..






Here she sat the next day as I stripped out everything else to start the cutting of the frame.








Measured about 10 times and cut once making this a pretty straight forward job. After looking at a few other peoples cuts and gusstes i ended up going with a Z cut and gusseted the frame on the inside. I removed exactly 16" inches from the frame which worked out perfectly in the end to line up all the holes. I had everything on about 8 jack stands jack stands to keep the truck perfectly level throughout the process.













For S and Gs we tossed the bed on to see how everything would look and line up. I was pleasantly surprised the body lines, and bolt holes for the bed and everything were spot on.




.

Last edited by slowcoupe; 11-24-2015 at 12:50 PM.
  #3  
Old 11-24-2015, 01:05 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

Pulled the bed back off to get everything tied together underneath.


Now a few things I couldn't find much about in the other threads. I had read the brake lines needed shortened and the e brake cable as well. No one really talked about how they secured the e brake cable once cut. Here is how i did mine and it looks factory.

I used wire cutters to shorten the actual cable. Looking at how the factory setup was secured I then went to home depot to look at wire clamps. Ended up purchasing a ferrule clamp kit and a swagging tool used to secure the ferrules to the factory cable. Measured and marked where the e brake would need to be positioned and clamped the ferrule into place. The factory cable had one ferrule in place but to be safe I backed a second right behind the first as a safety.

The fuel lines also need to be shortened. A good amount actually... I wanted to keep the factory vibrolock connectors atop the pickup so I cut the lines down at the frame and used 5 1/16" compression unions to connect the lines back together.

While I had everything out I did the Hutch and Harpoon mods in the tank and installed a Wix pre pump filter set up.


Go my new one piece driveshaft mounted up and bolted in place. My shaft total measurements from the rear diff housing to the face of the trans input was 56 1/8" in length. Now this is with the rear dropped 5" and the pinion angle at the proper position.I would suggest getting your suspension all setup before making these measurements as this could make a difference in how well your shaft fits.



Now it was time to fire up the truck. Fired right up and ran for a whopping 5 minutes and died.

Last edited by slowcoupe; 11-24-2015 at 01:10 PM.
  #4  
Old 11-24-2015, 01:58 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

Now it was time to fire up the truck. Turned the key over a few times and open the water drain on the rear of the housing. Bowl filled nicely. Fired right up. Checked all my fittings etc for leaks. Nothing! So I was excited to pull it out and take it for a test run. Truck ran for a whopping 5 minutes and died wouldn't restart. Things snowballed from here.

I immediately assumed CPS sensor as I had one go out on an old 7.3 and it felt the same when it died and no restart.

Used my dads scan gauge II on the truck and had all kinds of codes.

P1282 Excessive ICP

P0231 Fuel Pump Secondary

P0344 CMP Sensor Circuit Intermittent

and excessive run code. Don't remember exactly what that code was.

Started by replacing my CPS with the upgraded style since signs pointed to that with the crank but no start. Fired up again and died. Pulled he fuel filter from the bowl and depressed the tabs. No fuel in the bowl now. Dead fuel pump....

I went with an OEM fuel pump. Fired right up after replacing the pump and would idle for 7 minutes and would start to run very rough if you gave it any throttle, ICP would shoot up and it would die.

I read and read about problems people were having and came to the conclusion that I may have air locked my lines having undone all of my fuel lines and what not..

Banjo bolt removal for air bleeding is in no way a fun task. The whole front accessory system has to be removed and swung out of the way on the front and the rear passenger was nearly impossible to get with the downpipe in the way. But I was determine dot get it because after all this I was not removing the downpipe. Cracked them one at a time turned the key over and bleed air from each bolt. Tightened them down and proceeded to fire it back up. Still ran rough. looked over my entire fuel system and found not a fuel leak but a air leak pre pump on my fuel filter setup. One of the 1/2" WIX housing threads was not sealing. Since it was pre pump there was no pressure it wasn't leaking but when the demand for fuel was asked for by the pump it was pulling in air and causing the truck to die. Not even sure how we found this.
  #5  
Old 11-24-2015, 02:09 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

Since I have 0 room over the rear axle to run rear exit exhaust I was now at the point where i had to figure out what to do for exhaust. Thought about a fender exit 5" or just a side dump but i had this on my 6.4 for a while and it got my rear wheel and side of my truck filthy.

i decided to run a single short 7" mitre bedplate kit i built




Next I picked myself up a Goodmark Pro-EFX steel cowl hood. I debated if I liked the looks of a cowl hood because I al;ready liked the styling of the stock hood but I found a coupon code for the hood through a company at a price I couldn't beat so I did it. I sure am glad I did because this thing showed up and it is beautiful



I swapped on a 15' stepgate with emblem camera, and a paintable 2008 rear bumper after goign back and forth between a roll pan and a regular bumper. I have been rear ended a few times by dumb people not paying attention decided on such a small truck a regular old bumper back there would be best

  #6  
Old 11-24-2015, 02:16 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

This weekend I found up in Bakersfield a set of 40/20/40 smoke gray cloth seats from a 14'. I had been looking for a nice set of 05-15 seats for a while and swooped these up immediately. Picked up up Saturday installed them Sunday. Most of the bolts holes were there minus 2 for the center console front that needed to be drilled on the hump.

I had to remove the center headrest for shifter clearance but will be soon adding a Midwest short throw and modifying the shifter slightly to allow more room when shifting into 4th.




I also purchased a Insight CTS2 that i temporarily installed on the windshield mount but will be building a blend mount style mount for mount above my rear view like I did with my mini max in my 6.4


  #7  
Old 11-24-2015, 02:19 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

This is where I currently stand with the truck. Next on my list of things to do


-Midwest short throw

-22x9.5 wheels on 305/45/22 nitto 420

-05 Front end PTM conversion with a E-auto mesh grille(already purchased all of this and they are sitting in my spare bedroom at the house)

-Dream beams front 3" drop

And some body work for paint.
  #8  
Old 11-24-2015, 02:19 PM
shmoozer's Avatar
shmoozer shmoozer is offline
Major
Member's Gallery
 
Join Date: Jul 2012
Posts: 1,131
Default

Could just be me, but none of your pics work


Sent from my iPhone using Tapatalk
__________________
"I have 2 speeds, full throttle and reverse....even reverse is pretty fast" -South Mouth
  #9  
Old 11-24-2015, 02:21 PM
sootie's Avatar
sootie sootie is offline
General
Member's Gallery
 
Join Date: Oct 2012
Posts: 10,893
Default

work fine for me
  #10  
Old 11-24-2015, 02:37 PM
slowcoupe slowcoupe is offline
Lieutenant
Member's Gallery
 
Join Date: Feb 2012
Location: Las Vegas, NV
Posts: 783
Default

I checked my mobile and my work comp and I can see em. Let me know if everyone else can see em.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:32 PM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd