Go Back   PowerStrokeArmy > Power Strokes > 6.4 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 04-02-2019, 06:09 AM
BravoZulu81 BravoZulu81 is offline
Private
Member's Gallery
 
Join Date: Nov 2015
Location: Greer, SC
Posts: 42
Default Fuel milage getting worse

I have an 08 6.4 with about 190 on the clock, fully ******d GH tunes. When I first ******d just the *** my fuel milage rocketed up and it was awesome. I was getting 15-16 consistently. Once I ******d EGR and replaced my up pipes and down pipe unnoticed a weird drop.. wasnít huge and I put a camper top and new tires on around the same time so I assumed that was the cause. However recently it seems to be dropping and getting worse and worse. Back to the 13 range. Iíll give that it is time for oil and fuel filters but canít think thatís the issue. I seem to be building boost fine but power does seem a little off as well...

Any insights


Sent from my iPhone using Tapatalk
  #2  
Old 04-02-2019, 06:21 AM
kleake kleake is offline
Sergeant
Member's Gallery
 
Join Date: Jul 2016
Location: Sapulpa, OK
Posts: 345
Default

Sounds like an issue but driving speed, head wind, etc can really effect it. I have GH, exhaust, manifolds, pipes, etc. Empty at 70mph I get 18-19mpg. Push it up to 75mph and it drops to 16ish, headwind and it will drop a little more. Pull almost anything and it's in the 12mpg range. 36ft camper with boat behind and its 9mpg but that's a 25k load. These trucks really like the highway with minimal drag, but it doesnt take much to cause a drop in mpg. I'm not sure how much your topper effects it.

Sent from my SM-G960U1 using Tapatalk
  #3  
Old 04-02-2019, 07:25 AM
BravoZulu81 BravoZulu81 is offline
Private
Member's Gallery
 
Join Date: Nov 2015
Location: Greer, SC
Posts: 42
Default

Iím pretty well a granny and rarely get above 70mph as I notice it drop then too. Granted with my 37ís I donít expect anything like what you are getting but Iíve always had them and just feels different I guess.

What tune do you run? I may reload mine to see if that helps too.

Iíve also tried a few different additives to see if they help. Usually it seems like they do for the first 1/4 tank then falls off again.


Sent from my iPhone using Tapatalk
  #4  
Old 04-02-2019, 07:35 AM
kleake kleake is offline
Sergeant
Member's Gallery
 
Join Date: Jul 2016
Location: Sapulpa, OK
Posts: 345
Default

I'm running 35's so not much different. City driving also kills the mpg. If I drive around town I get in the low teens as well. My usual mix of 70% highway 30% city will put me at 14-15mpg average. I'm running GH with custom transmission settings. I run it in "street" mode most of the time on my mini maxx.

Sent from my SM-G960U1 using Tapatalk
  #5  
Old 06-07-2019, 08:02 AM
johnnyroastbeef's Avatar
johnnyroastbeef johnnyroastbeef is offline
Private
Member's Gallery
 
Join Date: Oct 2014
Location: South East PA
Posts: 35
Default

did you check your EBS sensor? i had mine replaced and i noticed better mileage, less smoke and more power. here is youtube vid about it: https://www.youtube.com/watch?v=_41i7ZM1ME4
__________________
-'09 CCSB, ARE intake, *** ******, EGR ******, H&S tuner, 35x12.5R20 Nitto Trail Grapplers, Alradco, PMF stage 2's, Detroit TruTrac,
  #6  
Old 06-07-2019, 10:36 AM
BravoZulu81 BravoZulu81 is offline
Private
Member's Gallery
 
Join Date: Nov 2015
Location: Greer, SC
Posts: 42
Default

Quote:
Originally Posted by johnnyroastbeef View Post
did you check your EBS sensor? i had mine replaced and i noticed better mileage, less smoke and more power. here is youtube vid about it: https://www.youtube.com/watch?v=_41i7ZM1ME4


I havenít checked that. Iím
Unable to watch the video right now but will ASAP. Is there a true diagnosis or just sorta a guess?


Sent from my iPhone using Tapatalk
  #7  
Old 07-11-2019, 10:32 AM
johnnyroastbeef's Avatar
johnnyroastbeef johnnyroastbeef is offline
Private
Member's Gallery
 
Join Date: Oct 2014
Location: South East PA
Posts: 35
Default

so i had the same MPG symptoms as you described. I also noticed a lot more smoke on acceleration. so I did some looking online and saw a lot of other 6.4 owners describing similar stuff and attributing it to the EBP sensor.
I had my mechanic just replace it as it was cheap and no more smoke and better MPG.
that was a while back and i'm starting to see the smoke increase again. I read that many guys also replace the tube that the EBP sensor connects to. so i'm already thinking of replacing that tube too.
but to answer your question i'm kinda throwing parts at it. as i understand the tube and/or sensor gets clogged with soot and can't properly read back pressure and the computer adds more fuel as a correction? thus producing more smoke and making MPG worse. (maybe someone smarter can explain that better?)
But if you're not seeing any additional/excessive smoke when you hit the gas, maybe your issue is something else.
__________________
-'09 CCSB, ARE intake, *** ******, EGR ******, H&S tuner, 35x12.5R20 Nitto Trail Grapplers, Alradco, PMF stage 2's, Detroit TruTrac,

Last edited by johnnyroastbeef; 07-11-2019 at 10:35 AM.
  #8  
Old 07-11-2019, 01:46 PM
BravoZulu81 BravoZulu81 is offline
Private
Member's Gallery
 
Join Date: Nov 2015
Location: Greer, SC
Posts: 42
Default

Certainly worth checking. Thanks


Sent from my iPhone using Tapatalk
  #9  
Old 07-11-2019, 05:58 PM
sootie's Avatar
sootie sootie is offline
General
Member's Gallery
 
Join Date: Oct 2012
Posts: 11,353
Default

Quote:
Originally Posted by johnnyroastbeef View Post
so i had the same MPG symptoms as you described. I also noticed a lot more smoke on acceleration. so I did some looking online and saw a lot of other 6.4 owners describing similar stuff and attributing it to the EBP sensor.
I had my mechanic just replace it as it was cheap and no more smoke and better MPG.
that was a while back and i'm starting to see the smoke increase again. I read that many guys also replace the tube that the EBP sensor connects to. so i'm already thinking of replacing that tube too.
but to answer your question i'm kinda throwing parts at it. as i understand the tube and/or sensor gets clogged with soot and can't properly read back pressure and the computer adds more fuel as a correction? thus producing more smoke and making MPG worse. (maybe someone smarter can explain that better?)
But if you're not seeing any additional/excessive smoke when you hit the gas, maybe your issue is something else.
No point replacing the tube unless it's plugged. You can achieve the same thing by poking a wire hanger thru it.

If the truck can't read ebp correctly, it has no idea where to place the veins of the high pressure turbo. Nothing to do with adding more fuel, it just doesn't push enough air to match the fuel it's being fed as the fail safe is to default open as opposed to closed to avoid blown head gaskets and the like
  #10  
Old 07-15-2019, 07:00 AM
BravoZulu81 BravoZulu81 is offline
Private
Member's Gallery
 
Join Date: Nov 2015
Location: Greer, SC
Posts: 42
Default

Quote:
Originally Posted by sootie View Post
No point replacing the tube unless it's plugged. You can achieve the same thing by poking a wire hanger thru it.



If the truck can't read ebp correctly, it has no idea where to place the veins of the high pressure turbo. Nothing to do with adding more fuel, it just doesn't push enough air to match the fuel it's being fed as the fail safe is to default open as opposed to closed to avoid blown head gaskets and the like


Makes sense. I havenít noticed any excessive smoke though. However I drive like a dang grandpa usually so rarely would I ever have seen anything.

Itís weird some days I also swear the truck feels more responsive and has more power. Sorta all sounds like it could be tied to this.

Would anything on this have changed when the truck was ******d which could be causing the issue?


Sent from my iPhone using Tapatalk
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:58 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Designed by Military Ltd