Go Back   PowerStrokeArmy > Power Strokes > 6.4 Tech

Reply
 
Thread Tools Display Modes
  #1  
Old 10-11-2018, 09:18 AM
thuglike's Avatar
thuglike thuglike is offline
Major
Member's Gallery
 
Join Date: May 2011
Location: Linden, NJ
Posts: 1,610
Default Injector 7 code

Yesterday, driving home from work I noticed the truck running a bit rough. (Out of the blue).

Got home, truck was idleing rough, and did a quick scan and got a open circuit code for #7. I think it was P0207.
I shut the truck down and restarted after a bit....truck was back to normal..no code/miss or rough idle. This morning going to work it was back ran rough had the code. Got to work shut down, can we back after a bit and restarted...no code/miss...Idled perfect. I'm guessing its injector selonoid or connection to it since it seems to be intermittent. Are the injector selonoids replaceable or would I need a new injector. I never really looked at it.
Thanks for any input.
  #2  
Old 10-21-2018, 09:26 AM
thuglike's Avatar
thuglike thuglike is offline
Major
Member's Gallery
 
Join Date: May 2011
Location: Linden, NJ
Posts: 1,610
Default

Update...

Be careful with the valve cover..

Just wanted to close out the mystery for the next guy having issues.
Attached Images
File Type: jpg 20181020_101232.jpg (1.40 MB, 18 views)
File Type: jpg 20181020_101117.jpg (1.37 MB, 18 views)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:02 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd