Go Back   PowerStrokeArmy > Power Strokes > 6.9-7.3 IDI

Reply
 
Thread Tools Display Modes
  #1  
Old 12-31-2013, 03:12 PM
Ad8 PRODIGY's Avatar
Ad8 PRODIGY Ad8 PRODIGY is offline
General
Member's Gallery
 
Join Date: Nov 2011
Location: Orange County, NY
Posts: 7,745
Default Thoughts on Stalling issue.

New fuel filter, no water in fuel... truck sat all summer. Plowed the last two storms and battled a stalling issue during the last one. Just replaced the fuel filter today and it did it immediately. Idles all day long, put it in drive and do a WOT run once moving and it stalls out like a lack of fuel... gonna add more to the rank tomorrow(wondering if the pickup in the tank broke more) and see what it does...

Any thoughts? Common problems associated with these symptoms on IDI's?
__________________
Zac
1994.5 F350 7.3L PSD Dually ZF5 - Daily Driver.
1993 F350 7.3 IDI - Retired to plow truck duty.

Quote:
Originally Posted by HairyPalmer View Post
not cool, man. Now I gotta get up from the computer with a boner and try to convince my wife I wasn't looking at porn.
  #2  
Old 12-31-2013, 09:44 PM
DarkSide2.6's Avatar
DarkSide2.6 DarkSide2.6 is offline
Corporal
Member's Gallery
 
Join Date: Oct 2012
Location: Maryland
Posts: 97
Default

Zac does it stumble and stall or just shut right off?

-Chris
__________________
2000 F-350 CCLB with a single S475
  #3  
Old 12-31-2013, 09:50 PM
Ad8 PRODIGY's Avatar
Ad8 PRODIGY Ad8 PRODIGY is offline
General
Member's Gallery
 
Join Date: Nov 2011
Location: Orange County, NY
Posts: 7,745
Default

Quote:
Originally Posted by DarkSide2.6 View Post
Zac does it stumble and stall or just shut right off?

-Chris
Pretty much starts dying off and within the next 2 seconds its dead
__________________
Zac
1994.5 F350 7.3L PSD Dually ZF5 - Daily Driver.
1993 F350 7.3 IDI - Retired to plow truck duty.

Quote:
Originally Posted by HairyPalmer View Post
not cool, man. Now I gotta get up from the computer with a boner and try to convince my wife I wasn't looking at porn.
  #4  
Old 12-31-2013, 09:53 PM
DarkSide2.6's Avatar
DarkSide2.6 DarkSide2.6 is offline
Corporal
Member's Gallery
 
Join Date: Oct 2012
Location: Maryland
Posts: 97
Default Thoughts on Stalling issue.

Any chance the fuel pump is weak and not supplying enough fuel for the wot run?

-Chris
__________________
2000 F-350 CCLB with a single S475

Last edited by DarkSide2.6; 12-31-2013 at 10:02 PM.
  #5  
Old 12-31-2013, 10:03 PM
Ad8 PRODIGY's Avatar
Ad8 PRODIGY Ad8 PRODIGY is offline
General
Member's Gallery
 
Join Date: Nov 2011
Location: Orange County, NY
Posts: 7,745
Default

Quote:
Originally Posted by DarkSide2.6 View Post
Any chance the fuel pump is weak and not supplying enough fuel to the IP for the wot run?

-Chris
I hope not lol. I'm gonna add 5 gallons tomorrow. It had the pickup tube problem after 1/8 tank it wouldnt pickup and would die. Its at 1/4 tank and I'm wondering if the pickup tube got worse over the summer. It also had a fuel leak from the steel line on the frame rail over the summer... got some rubber hose and I'm gonna throw it where I roughly found the leak and see if it clears it up... maybe its sucking air... idk
__________________
Zac
1994.5 F350 7.3L PSD Dually ZF5 - Daily Driver.
1993 F350 7.3 IDI - Retired to plow truck duty.

Quote:
Originally Posted by HairyPalmer View Post
not cool, man. Now I gotta get up from the computer with a boner and try to convince my wife I wasn't looking at porn.
  #6  
Old 01-01-2014, 06:29 AM
DarkSide2.6's Avatar
DarkSide2.6 DarkSide2.6 is offline
Corporal
Member's Gallery
 
Join Date: Oct 2012
Location: Maryland
Posts: 97
Default

When you add the fuel put some fuel conditioner in also, just for piece of mind. Hope it's something simple and cheap!

-Chris
__________________
2000 F-350 CCLB with a single S475
  #7  
Old 01-06-2014, 08:18 PM
HuSlungDu HuSlungDu is offline
Corporal
Member's Gallery
 
Join Date: Sep 2013
Location: Helotes, TX
Posts: 50
Default

i had a problem with mine on the rubber line going from the frame rail to the lift pump. it would collapse after a little bit of suction. eventually it would open up, truck would start and then it would suck it closed again. you can tell just by reaching down there and squeezing it.
__________________
2006 6.0 4x4 ECLB PMM ******, ******** SRL+, 4" Magnaflow, Blue Spring, 66 non-VGT, 190/75, 6.4 banjos, Ported Intake, Coolant Filtration, 20x12 Moto's w/ Toyo a/t
  #8  
Old 01-06-2014, 10:25 PM
Ad8 PRODIGY's Avatar
Ad8 PRODIGY Ad8 PRODIGY is offline
General
Member's Gallery
 
Join Date: Nov 2011
Location: Orange County, NY
Posts: 7,745
Default

Forgot to update this... I guess I over thought it and didn't check the oil... it was halfway to the end of the stick past the "add" mark. Filled it up and added 5 fresh gallons of diesel and it ran fine. Has a funky idle sometimes like when I'm sitting at a light. If I put it in park or neutral it will smooth out.. did stall twice on me on a pretty steep driveway tho... I put it in park on the driveway and hopped out.. idle got chitty and it died a second or two later... not sure at the moment anymore..
__________________
Zac
1994.5 F350 7.3L PSD Dually ZF5 - Daily Driver.
1993 F350 7.3 IDI - Retired to plow truck duty.

Quote:
Originally Posted by HairyPalmer View Post
not cool, man. Now I gotta get up from the computer with a boner and try to convince my wife I wasn't looking at porn.
  #9  
Old 01-07-2014, 07:04 AM
DarkSide2.6's Avatar
DarkSide2.6 DarkSide2.6 is offline
Corporal
Member's Gallery
 
Join Date: Oct 2012
Location: Maryland
Posts: 97
Default

Get that pickup tube fixed
__________________
2000 F-350 CCLB with a single S475
  #10  
Old 03-01-2014, 12:05 AM
Jaredkeller96's Avatar
Jaredkeller96 Jaredkeller96 is offline
Sergeant
Member's Gallery
 
Join Date: Jul 2013
Location: Crawfordsville Indiana
Posts: 274
Default

when i had my idi motor it would idle all damn day long go to drive it nothing! it had two inline fuel filter and thats what made it do that. and we did check the pick up. we put in new fuel filter, pump and even replaced most of the injector lines
  #11  
Old 03-01-2014, 10:22 AM
Ad8 PRODIGY's Avatar
Ad8 PRODIGY Ad8 PRODIGY is offline
General
Member's Gallery
 
Join Date: Nov 2011
Location: Orange County, NY
Posts: 7,745
Default

Forgot to update this. Ended up giving out on me in a driveway. Fuel line went in like 3 spots. Ran a soft line from the tank to as far as I could go... a all better now. Its would suck air and die when I pinned it because it had holes in the line

Always something simple with this truck lol

Thanks for the help tho guys, gave me a good starting point on it
__________________
Zac
1994.5 F350 7.3L PSD Dually ZF5 - Daily Driver.
1993 F350 7.3 IDI - Retired to plow truck duty.

Quote:
Originally Posted by HairyPalmer View Post
not cool, man. Now I gotta get up from the computer with a boner and try to convince my wife I wasn't looking at porn.
  #12  
Old 03-01-2014, 04:32 PM
DarkSide2.6's Avatar
DarkSide2.6 DarkSide2.6 is offline
Corporal
Member's Gallery
 
Join Date: Oct 2012
Location: Maryland
Posts: 97
Default

Good deal, glad you fixed it!
__________________
2000 F-350 CCLB with a single S475
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:53 AM.

 

Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Designed by Military Ltd