03 6.0 injector replacement

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
Have a Early 03 6.0, clouds of white smoke, to much fuel, run it for awhile, shut it off then no crank, hydro lockEd, going to put all injectors in it just stock, would you put motorcraft or Alliant back in it $1600-$1800 set. Thanks
 

6.0 Tech

Well-known member
Joined
Sep 9, 2015
Messages
3,351
Reaction score
54
Location
Mesa, AZ
Motor raft has a better warranty, so if it’s around the same price I’d go that route


Sent from my iPhone using Tapatalk
 

bismic

Member
Joined
Jul 3, 2011
Messages
329
Reaction score
4
Alliant now has a distribution partnership with Pure Power. They sell the new ones made by Pure Power (who was always the original manufacturer and re-manufacturer - formed in 1999 as a joint venture between Navistar and Siemens).

Alliant also sells re-manufactured injectors by Pure Power- so whichever you desire should be fine .....
 
Last edited:

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
Hello I took the glow plugs out cranked it over, the #5 injector was the one putting to much fuel in making it hydro lock and smoke, bought a endoscope looked in cylinder, looked good to me, really don’t know much about it, looked like some oil in there from glow plug out, it also burnt the tip end off glow plug, but drove 120 miles with stock trailer don’t think hurt piston, should I have compression test done or just put injector and glow plugs in see what happen, everything is still stock. Last one think is valve. Thanks
 

Attachments

  • 0F4D18C7-D3F1-4417-BC36-C872C4BA6C3A.jpeg
    0F4D18C7-D3F1-4417-BC36-C872C4BA6C3A.jpeg
    38.8 KB · Views: 19
  • 239B2DA5-469B-4F60-8CF2-2FAF611956E0.jpeg
    239B2DA5-469B-4F60-8CF2-2FAF611956E0.jpeg
    37.9 KB · Views: 21
  • 280E0BF6-2763-48F3-8102-6E1A6E97EBBE.jpeg
    280E0BF6-2763-48F3-8102-6E1A6E97EBBE.jpeg
    36 KB · Views: 21
  • 99744FB3-37AA-4D82-B3F2-C3C89FF871B4.jpeg
    99744FB3-37AA-4D82-B3F2-C3C89FF871B4.jpeg
    37.9 KB · Views: 20
  • BA820D00-7E03-4943-A73F-4CADC74EC4BC.jpeg
    BA820D00-7E03-4943-A73F-4CADC74EC4BC.jpeg
    41.4 KB · Views: 14

6.0 Tech

Well-known member
Joined
Sep 9, 2015
Messages
3,351
Reaction score
54
Location
Mesa, AZ
Hello I took the glow plugs out cranked it over, the #5 injector was the one putting to much fuel in making it hydro lock and smoke, bought a endoscope looked in cylinder, looked good to me, really don’t know much about it, looked like some oil in there from glow plug out, it also burnt the tip end off glow plug, but drove 120 miles with stock trailer don’t think hurt piston, should I have compression test done or just put injector and glow plugs in see what happen, everything is still stock. Last one think is valve. Thanks

Piston looks ok. Doesn’t look like anything was bouncing around in the cylinder. I’d throw an injector in it and see how it runs, if it still misses real bad or has a skip while cranking then you’ll need to have a compression test and leak down test done


Sent from my iPhone using Tapatalk
 

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
Piston looks ok. Doesn’t look like anything was bouncing around in the cylinder. I’d throw an injector in it and see how it runs, if it still misses real bad or has a skip while cranking then you’ll need to have a compression test and leak down test done


Sent from my iPhone using Tapatalk
Ok Thanks, I’ll put it back together see what happens, going to change oil again, Icp been bad for while, change it and connector, let you know day or two.
 

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
Hay 6.0 tech, I put injector in, I put icp and connector, Cranks over good, no skip, check engine light went out, smoked for about 15-20 min, sounds good runs good. Guess I can take a load of heifers to the sale sat. Thanks so much for the help
 
Last edited:

6.0 Tech

Well-known member
Joined
Sep 9, 2015
Messages
3,351
Reaction score
54
Location
Mesa, AZ
Hay 6.0 tech, I put injector in, I put icp and connector, Cranks over good, no skip, check engine light went out, smoked for about 15-20 min, sounds good runs good. Guess I can take a load of heifers to the sale sat. Thanks so much for the help

No problem man. Glad it’s running. What did the injector look like when you pulled it?


Sent from my iPhone using Tapatalk
 

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
It looked like the tip was cracked, o-rings looked good, #5 same one I replaced about 7 years ago, came from BRD, the other 7 came in truck when new, the ICP looked kind of melted, I put glow plugs and new wire harness on to, I been running shell 15-40 oil since I had the truck, change it every spring weather it 500 miles or 3000 miles, don’t drive it all time, some say to run mobile 5-40 better oil, I just changed it Sept. when this happened, but due to all this going to change it now, along with antifreeze, it shore does start easer turns over one time and starts, use to be 8-10 times. Ok man thanks
 

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
Had any issues with water in your fuel?
Using OEM fuel filters?
No not water, I messed up about 2 years ago grabbed the wrong pump and put about 2gal of gas in it, but have run empty 8-10 tanks of fuel threw it since and used sea foam, was going to drain the tank but every body said it would be ok, I always use all motor craft filters.
 

bismic

Member
Joined
Jul 3, 2011
Messages
329
Reaction score
4
I don't believe that 2 gallons of gas would cause an issue. I just usually think of water when I hear of a cracked injector tip (and I suppose it could just be age related, but I don't think that is common). Another possibility might be low fuel pressure. For cost management reasons (injectors are expensive), I believe that every 6.0L owner needs to have a fuel pressure gauge and maintain pressure at 50 psi to 75 psi.
 

Cattleman

New member
Joined
Oct 16, 2022
Messages
10
Reaction score
1
Location
West Virginia
I pull the plug on the pump under cab, haven’t seen much water come out, but only takes one drop, looked like hair line crack but may have just been stock open pouring fuel in, got some hot shot secret for fuel and oil they say it’s good. Expensive to, 49 a bottle.
 
Last edited:

Latest posts

Members online

Top