Full Boost???

Fordman03

New member
Joined
Dec 19, 2022
Messages
5
Reaction score
1
Location
Alberta, Canada
Hey all... Well I just bought my second F450 with the 6.4 This one has been deleted but there is no tuner with the truck. Anyway I had a check engine light on and it showed up as p132b if im correct. Thats a turbo code. The truck has lots of boost...but it seems to be to much... driving at around 60 its at full boost. It did want to stop on me last night.. it seemed to loose power and I let off... the boost went down to half and it got power back. Could have been the cold to.. since it was 35 below....but Im curious why this is happening? Any thoughts...
Thanks
 

Powerstroke Cowboy

Well-known member
Joined
May 20, 2011
Messages
3,981
Reaction score
91
Location
Montana
Sounds like your vgt controller is bad. Thats one of the ways they act when it gets cold.

What was the air temperature?

If your not careful and keep running it, you might blow your head gasket.

That's what happened to me.
 

Powerstroke Cowboy

Well-known member
Joined
May 20, 2011
Messages
3,981
Reaction score
91
Location
Montana
It was -35 celcius that day.
Welcome to PSA!

I am almost 100% sure it's the VGT controller. There not cheap. But it's a lot cheaper than blown head gaskets.

The factory ones were known to have problems. There is an updated one out there.

On Edit: just notices your first post said it was 35 below when it happened. I must have missed that detail. Sorry about that.
 
Last edited:

6.0 Tech

Well-known member
Joined
Sep 9, 2015
Messages
3,351
Reaction score
54
Location
Mesa, AZ
Hey all... Well I just bought my second F450 with the 6.4 This one has been deleted but there is no tuner with the truck. Anyway I had a check engine light on and it showed up as p132b if im correct. Thats a turbo code. The truck has lots of boost...but it seems to be to much... driving at around 60 its at full boost. It did want to stop on me last night.. it seemed to loose power and I let off... the boost went down to half and it got power back. Could have been the cold to.. since it was 35 below....but Im curious why this is happening? Any thoughts...
Thanks

Check your ebp reading key on engine off. Compare it to map and bark, it should be fairly close to both the other readings. Ford’s spec is within 1.5psi, but typically it’s much closer than that, like within .5psi


Sent from my iPhone using Tapatalk
 

Fordman03

New member
Joined
Dec 19, 2022
Messages
5
Reaction score
1
Location
Alberta, Canada
Welcome to PSA!

I am almost 100% sure it's the VGT controller. There not cheap. But it's a lot cheaper than blown head gaskets.

The factory ones were known to have problems. There is an updated one out there.

On Edit: just notices your first post said it was 35 below when it happened. I must have missed that detail. Sorry about that.
Thank you!! DO you think I should get a tuner and reflash it maybe?
 

Powerstroke Cowboy

Well-known member
Joined
May 20, 2011
Messages
3,981
Reaction score
91
Location
Montana
If the VGT controller is bad. A new tune will not change that at all.

You can still buy the mini maxx in Canada if you want to go that route.
 

Latest posts

Members online

Top