Corrupt minimax files?

Mphomes1

New member
Joined
Dec 5, 2021
Messages
4
Reaction score
0
I need some help with chasing a gremlin and I’m hoping someone else here might have the answer. My 6.4 began occasionally dying at stoplights but would restart and die at the next stoplight etc. No Codes and Mild Tune. That has finally evolved to it would start and move about 10 feet and die and not restart until the next day. It is not throwing any codes. After searching several topics I landed on the low pressure fuel pump or fuel conditioner was going bad. I replaced that part and the truck started right up and sounded great. As soon as I threw it in gear to take it for test drive it died and would not restart. This was with the MM mild tune installed. I re-bled the fuel system and it did not change anything. On a whim I uninstalled the mild tune and installed the easy tune and the truck starts and idles (the idle starts to shimmy after 10 minutes or so). It drives ok but is in limp mode. I can at least drive it without it dying and it continues to start and sound just fine. It did throw codes associated with the EGR and a code P-2289 injector control pressure too high - engine off. If I uninstall the tuning and return it to stock it will not even turn over. If I reinstall the mild or wild tune it will sometimes start and idle for a minute or two and then die and not start again. It does not throw any codes when tuned to OEM, Mild, or Wild. Has anybody run into something like this and does anybody have any advice?
 

sootie

Well-known member
Joined
Oct 3, 2012
Messages
11,850
Reaction score
28
its nothing to do with the tuning, i can assure you. Figure out the mechanical problem with your truck.
 

6.0 Tech

Well-known member
Joined
Sep 9, 2015
Messages
3,467
Reaction score
93
Location
Mesa, AZ
I need some help with chasing a gremlin and I’m hoping someone else here might have the answer. My 6.4 began occasionally dying at stoplights but would restart and die at the next stoplight etc. No Codes and Mild Tune. That has finally evolved to it would start and move about 10 feet and die and not restart until the next day. It is not throwing any codes. After searching several topics I landed on the low pressure fuel pump or fuel conditioner was going bad. I replaced that part and the truck started right up and sounded great. As soon as I threw it in gear to take it for test drive it died and would not restart. This was with the MM mild tune installed. I re-bled the fuel system and it did not change anything. On a whim I uninstalled the mild tune and installed the easy tune and the truck starts and idles (the idle starts to shimmy after 10 minutes or so). It drives ok but is in limp mode. I can at least drive it without it dying and it continues to start and sound just fine. It did throw codes associated with the EGR and a code P-2289 injector control pressure too high - engine off. If I uninstall the tuning and return it to stock it will not even turn over. If I reinstall the mild or wild tune it will sometimes start and idle for a minute or two and then die and not start again. It does not throw any codes when tuned to OEM, Mild, or Wild. Has anybody run into something like this and does anybody have any advice?

Sounds like an frp and under valve cover harness possibly, air in the fuel system still, shit hi pressure pump, basically what Sootie said. He’s pretty smrt when it comes to these. The icp too high engine off code leads me towards frp and uvc, but without having a scanner on it can’t tell ya for sure


Sent from my iPhone using Tapatalk
 

Mphomes1

New member
Joined
Dec 5, 2021
Messages
4
Reaction score
0
6.0 Tech and Sootie, I appreciate the responses. I have replaced the frp before around 15k miles ago, but it didn’t present like this, but I wouldn't be surprised if that’s the culprit. I’ve wondered about the under valve cover harness. If the Hpp is bad wouldn’t I see metal particulate in the fuel filter sumps? Or is that not always the case?
 

Latest posts

Members online

Top